TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
388 Posts
Discussion Starter #1
Just wondering if anybody has changed the LED's on the wing that was 'factory' or dealer installed on many of our cars. Mine appear to have burned up. thanx!
 

·
Administrator
Joined
·
4,161 Posts
LED's don't burn up. Their life expectancy is in the hundreds of thousands of hours. Determine that you do indeed still have voltage going to them first.
 

·
$.25 poster
Joined
·
1,900 Posts
So please explain our tailights then :rolleyes:


:D
 

·
Administrator
Joined
·
4,161 Posts
The problem with the tails is not the LEDs themselves, but a poorly thought out circuit board arrangement. The boards take too much vibration and the traces break when you slam the trunk too much. But if you pull the LED's they're fine.
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
Yep, I've had a circuit board out and in a electrical lab. The LED's are fine, the resistors are fine, it's just the board that sucks.

Doesn't help they are one of kind. Professor who has been working with LEDs for 10 years had never seen anything like it.
 

·
Registered
Joined
·
388 Posts
Discussion Starter #8
ARggg...for some reason im not getting my reply notification on my email account. Ill have to check out why.....anyways, ill double check on the voltage going to the LED's then. I remember my ex saying at soem point that there were two out, then three...then all of them went. Ill let u guys know what i can find.
 
1 - 8 of 8 Posts
Top