TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hoping someone here can help me out with my 97 4.6 bird. A little background first.
I replaced my leaking intake with a NPI intake with the al. crossover. We have also replaced:

IAC, MAF, crankshaft position sensor, all three catalytics, 4 new O2 sensors, wires and plugs.
Now to the current problem. She is throwing the current codes:
P1445, P0135, P0141, P0155 and P0161. I have checked the fuse for the 02 sensors and my father in law (who is a mechanic) tells me that all of the wiring harnesses are in good condition. Does anybody have any ideas? I know that the P1445 is telling me that there is an issue with the purge flow sensor, but could that be cause the O2 sensors to send a code? :confused:

The car is running great and fuel mileage does not seem to be an issue either.

Thanks for any advice!!!
 

·
Newbie
Joined
·
5,650 Posts
P0135, P0141, P0155, and P0161 indicate that all the 02 sensors have a circuit problem. Since you said all the fuses and the wiring harness were checked (and I assume your father-in-law also checked that the sensors were getting power), I can only think that the wrong 02 sensors are installed. I would think it to be near impossible that all 4 sensors are bad.

P1445 indicates that the purge flow sensor input is high. This would not be caused by the 02 sensors. The purge flow sensor is known to go bad on these cars. It is up front by the charcoal canister. There are emissions lines running from the canister to the engine, and there is a purge solenoid followed by the purge sensor. Replace it and that problem should be resolved.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
thanks master486!
I am reasonable certain that the o2 sensors are the correct ones. we have changed them before without any problems and we used the same part number to order the latest set.
I will replace the purge sensor since that is relatively inexpensive. My main concern right now is that the PCM may be bad and I do not want to start replacing parts that are good just because the computer thinks they are bad.
Thanks again!
 
1 - 3 of 3 Posts
Top