TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hello, I am looking for any advice about replacing my tranny in my 94 LX (4.6 V8). I just got some things done to get the car running right (need to update my previous posting) but now the tranny seems to be slipping. It does not seem to be running in synch with the motor. At a stop it hesitates, kicks a bit, and slowly brings up the RPMs before it finally seems to catch up. There is definitely a problem with it, Should I look for a used one to swap out, my local mechanic suggested a flush, new fluid and filter, but couldn't gaurantee that it would fix the problem.

Thanks for the help.

Jeff
 

·
Registered
Joined
·
654 Posts
Change the fluid using Mercon V "drain the torque convertor it has a
drain plug" uses about 12 qts.

When changing fluid it is a good idea to also change the 1-2 accumulator &
springs "under $20.00" Go to the Tech Article page click on Transmission
very good stuff :)


CurtisA
 

·
Registered
Joined
·
2,894 Posts
ct to mi, long ways, but id go for that, slap a cooler and j-mod on millers tranny, and youl be good for a while after that, but what ever you do, get the CEL off before you go for sevre stuff like tranny, your problem may be in your CEL, ud be suprised how funny a car can act with a bad sensor
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Thanks for the info, sorry but what is the CEL. I am still getting used to the T-bird lingo.

Thanks

Jeff
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Gotcha, I am getting the car re-coded this week. I will have my mechanic write down the code\codes.
 
1 - 7 of 7 Posts
Top