TCCoA Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
645 Posts
Discussion Starter · #1 ·
As some of you know, I have become the owner of a 89 Mark VII LSC. Well, after putting a new battery and cables/terminals the car fired right up, but it's idling smoothly at around 1300 rpms and won't rev above 2500 rpms.

I checked the fuel pressure and it's about 30 psi with the vacuum line pulled from the regulator. That's a little low isn't it? Could this be causing the cutout at higher rpms?
I checked the fuel filter and it looks to be the original so I'm gonna replace it with a new purolator.

I ran a self test and pulled KOER codes 12, 22, 94, 44, and 18.

Code 12 is an IAC low. I took the IAC off and watched it when the key is turned on. It's moving so I'm thinking it's ok. It might be possible the idle screw is adjusted too far in? I'll have to check it.

Code 18 is check base timing and advance. I pulled the spout and checked the base timing and it's at 10* BTDC but it was intermittent. There's a possibility it's my timing light causing the intermittent though. Is it possible the TFI module is bad?

The other codes I'm not sure about.

Any info or info on the codes would be greatly appreciated. Thanks in advance! :D
 

·
Banned
Joined
·
538 Posts
PIP and check the coil :) been there done that, pretty much all of it so far.
 

·
Banned
Joined
·
538 Posts
and yes your fuel pressure is low.
 

·
Registered
Joined
·
320 Posts
Also you might have an exhust restriction. Maybe something in the exhust is pluged up. You said the fuel filter looks factory what about the cat? Those get pluged and the motor won't want to run much less Wrap up to higher RPM's
 

·
Registered
Joined
·
1,095 Posts
How do the spark plug wires look? My ranger wouldn’t rev past 3,000rpm and basically backfire until I let off. Turned out the wires were making a fireworks show when I checked them at night with the engine running.
 

·
Registered
Joined
·
645 Posts
Discussion Starter · #9 ·
I've made a little progress so far.

Putting a new fuel filter on didn't fix the fuel pressure, but it's good maintenance.

The fuel pump was going out. It had low pressure and sounded like a dying cow. I actually have video if you wanna hear it.
http://video.google.com/videoplay?docid=-3932374013149470505

I replaced the fuel pump with a new walbro 255 lph and the fuel pressure is 40 psi with the vacuum pulled so that's ok.

I listened to all of the injectors with a stethoscope and they're all clicking so I would say they're ok.

The cats seem to be fine. The exhaust smell is normal and this was a California car. :D

Another problem I found was that the car was charging at 18 volts and draining the battery overnight, due to a bad voltage regulator. The VR is separate from the alternator on a Mk VII so I put a new one on.

I've put on two other map sensors from mark viis and it didn't change anything so I'm thinking the map sensor is probably ok.

I have fuel now and I'm getting air so I'm looking at the ignition. It's in time and the chain has no slack.

The cap and rotor and wires are original so I'm gonna replace those. The plugs are probably original too.

Tomorrow I'm gonna take the tfi module off and have it tested, and if it's bad then I'm gonna replace that.

That's all I know for now, I'll keep this posted.
 

·
Registered
Joined
·
2,666 Posts
Here is a test for the TFI module on an 84 Vic w/ the 5.0. Not sure if it translates to your car or not, but it may be usefull.



Jay
 

·
Registered
Joined
·
645 Posts
Discussion Starter · #12 ·
I took the TFI module off today and had it tested. It tested good 3 times in a row, so I'm thinking it's ok. I also used an ohmmeter to check the connections like fordman put up and it was within spec.

I have some ford racing wires and a msd cap and rotor coming. When they get here I'll put them on with the as42c plugs and see if they help any. I doubt they'll fix it, but it definitely needs new ones cause they've been on there for 17 years and 133,000 miles now.
 

·
Registered
Joined
·
645 Posts
Discussion Starter · #14 ·
I found the problem.

It's not the motor it's the dumbass transmission. It won't let the engine rev in park. Reverse and overdrive aren't working, so for some reason it tries to pull forward in neutral and park :confused: It's not the linkage. I checked it and it seems to be fine. I'm guessing it's nothing a good rebuild won't fix. Forget rebuild though cause it's T5 time for this one. :D

Anyhow 1-3 are working decent and I can nail it and it pulls strong to redline like it's supposed to.

I also did a tune up which the car badly needed. Someone had installed 7 shi*fires and left one of the original motorcraft plugs.

It does still idle around 1,000 rpms though. I'm thinking a vacuum leak at this point. The IAC is new.
 

·
Registered
Joined
·
645 Posts
Discussion Starter · #15 ·
The high idle was a vacuum leak. The hoses running to the MAP sensor and the charcoal canister were both broken open at the nipples under the manifold. It's idling ~700 rpms now so I'll take that. :D
 

·
Registered
Joined
·
892 Posts
The high idle was a vacuum leak. The hoses running to the MAP sensor and the charcoal canister were both broken open at the nipples under the manifold. It's idling ~700 rpms now so I'll take that. :D
You should be named the resident diagnostic. You solved all your own problems. Hmmmmmmmmm, a Mark VII with a stick, cool. Great work.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top