TCCoA Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
Uhhh... my car's not leaking any oil yet it seems to be disappearing... burning off? I top it up... little while later the VMM reads that the oil is low... go check the dipstick and sure as hell the oil's low. I top it up and it stays like that for awhile... and eventually its low again... common w/ SC's? Or have my hg's gone? My dad says it could be the rings (guessing piston rings)? and not the hg's. I don't seem to be burning rich. A little bit of steam (maybe smoke... its white tho) in the morning or when the engine's just started after sitting for a couple hrs? Any input anyone? Thanks for any input
-Chris
 

·
Registered
Joined
·
1,046 Posts
The smoke, does it smell terrible? It's probably your oil burning off on your exhaust manifolds and catalytic converters. I would check to see if you have a huge leak somewhere around your lower intake. There or near the harmonic balancer. Anywhere that could let oil get on your headers.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #4
ummmm.. coolant? Not sure what it looks like. The resovoir isn't ful enough for me to see it... i might open up the radiator and check it sometime this weekend if i can catch it cool. Otherwise i'm gonna climb under the car and see if there's any leaks. I heard it could be piston rings... valve covers... and sumthing else... can't think of it right now
{EDIT} Uhhh... it doesn't smell bad... i don't think? I didn't walk through it or walk up and smell it but it wasn't noticeable when driving or stopped at the store (while idling) when i was sitting in the car so it can't be THAT bad...
 

·
Registered
Joined
·
1,046 Posts
My old 5.0 leaked around the oil pan seal and it burned off on the headers. Your problem sounds similar.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #6
I'm not seeing anything on the ground... but if that is my problem then what did you do to fix it?
 

·
Registered
Joined
·
1,046 Posts
I didn't fix it, but I figure a lot of RTV sealant around the oil seal would work. Or you can pull the engine and replace the seal. I never saw oil on the ground either, I just saw it on my cats.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #8
Me?! Pull the engine?! HA! I don't think i'd do that, actually i couldn't do that if i tried! Do you just keep an eye on your oil or did u sell the 5.0? I'll climb under there and check.. i wanna see what kind of exhaust i got on there anyways...I bought it (the sc w/ exhaust) and all he said was that it had an "After Market Stainless Steel" exhaust, and the only aftermarket stainless steel is Borla (from what I know) So i'm gonna climb under there and look for some stamps or anything... thanks for ur help, i'll let yea know how it goes... i'll do it over the weekend sometime... i don't have it right now.
 

·
Registered
Joined
·
1,046 Posts
The last owner of your car could have meant the MN12 Performance Stainless Steel ehxuast system, which is a stainless system from highflow cats back to the mufflers. MN12 Performance no longer sells that system. I have that system also.

I just made sure to watch my oil level and eventually I sold the 5.0.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #10
I'll keep that exhaust thing in mind... either way it sounds great... i just wanna know what exhaust it is for a mods list when i finally start one :)
 

·
Registered
Joined
·
1,046 Posts
I'm not sure exactly what makes up the system, but I have read good reviews. MN12 Performance put a lot of work into it.

Good luck with your oil leak :thumbsup:
 
1 - 11 of 11 Posts
Top