TCCoA Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
The last fuse in my distribution box isnt there.. it says it's supposed to be a ' Mega fuse ' ... ?? what exactly is a ' mega fuse ' ... is says ' distribution box ' wher that fuse is supposed to go in my owners manual.. also there's no abs fuse.. this normal?
 

·
Registered
Joined
·
680 Posts
If the mega fuse is the 175A fuse, then it should be on the side of the box with the coolant hose connected to it via clip.
 

·
Chapter Director Coordinator
Joined
·
6,253 Posts
you mean the fuse the battery and starter cables meet up at ? w/ the little cover over it?
 

·
Registered
Joined
·
2,717 Posts
Anyone blown one of those fuses besides me????

LOL!

Like 94mncougar said, it's the 175 amp fuse located where he said.
 

·
Registered
Joined
·
401 Posts
Anyone blown one of those fuses besides me????

LOL!

Like 94mncougar said, it's the 175 amp fuse located where he said.
i did! lol....grounded the alt, good times
 

·
Fry Rice Specialist
Joined
·
4,794 Posts

·
Registered
Joined
·
3,180 Posts
what happens when this fuse is blown?
Why, what isn't working? If you have a blown 175 amp fuse it won't be too hard to figure out.
 

·
Super Moderator
Joined
·
10,588 Posts
Well if you have no ABS then it's normal to not have the fuse.
No... The megafuse is there on no-abs cars, too.

I have two of them.
 

·
Registered
Joined
·
3,180 Posts
I think he also mentioned there's no ABS fuse in the engine bay fuse box and was wondering if that's normal or not. I guess that depends on if you have ABS or not...
 

·
Super Moderator
Joined
·
10,588 Posts
I think he also mentioned there's no ABS fuse in the engine bay fuse box and was wondering if that's normal or not. I guess that depends on if you have ABS or not...
I missed that part...oops.
 

·
Registered
Joined
·
680 Posts
Ha, I misunderstood as well. Did you figure out why that fuse was blown?

- Stephen
 

·
Registered
Joined
·
2,717 Posts
For me, the car wouldn't start. As I was fiddling with things, I noticed that the fuse was making a noise when I shook it. I think realized that the puff of smoke a few minutes earlier had blown the fuse......yeah I'm brilliant...
 

·
Premium Member
Joined
·
9,165 Posts
Anyone blown one of those fuses besides me????

LOL!

Like 94mncougar said, it's the 175 amp fuse located where he said.
Yea, we blew one. We didn't unhook the battery while doing a cam swap and at one point we arced across the terminals.. Blew that dude big time. Funny thing is I didn't even know it was a fuse till I replaced a couple alt. and other things trying to fix it. I finally gave it a good, close, look and saw the connector. Those ain't cheap fuses either!
 
1 - 17 of 17 Posts
Top