TCCoA Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
well im having even more problems with my baby. First question... at what rpm should my car shift into fourth at part throttle? Is there a reason my car wont shift into third or fourth? i just got done installing 3.73 gears, trango shift kit, and 3000 rpm stall converter. it wont shift out of second now no matter what i do. the transmission worked fine before i did these mods. Also i dont have a chip...Yet..

thanks for the help.
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
Can't rule out the MLPS...but to me it sounds like a faulty shift-kit.
 

·
Registered
Joined
·
1,565 Posts
GreenBird said:
Can't rule out the MLPS...but to me it sounds like a faulty shift-kit.
shifting is almost completely controlled by the computer, and input from the MPLS. i think a faulty shift kit would cause different problems with an electronically controlled transmission.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #5 ·
umm stupid question, what is the mlps? j-rob what rpm did your car shift at before you got your chip installed. my 1-2 is fine just 2-3 and 3-4 shifts aren`t there. im going to put the chip in wednesday i guess and see if that helps.
 

·
Registered
Joined
·
1,565 Posts
nitrofreak said:
umm stupid question, what is the mlps? j-rob what rpm did your car shift at before you got your chip installed. my 1-2 is fine just 2-3 and 3-4 shifts aren`t there. im going to put the chip in wednesday i guess and see if that helps.
Manual Lever Position Sensor... causes lots of problems occasionally

i couldnt tell you exactly where it shifted at part throttle from 2-3, probably somewhere between 1500 and 3000 depending, a little lower for the 3-4.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #7 ·
even more pissed

well i got the dennis chip hoping it would help. well no change. should i go ahead and replace the sensor or maybe start thinking of buying a new valve body. i never had a problem with this car until i did those mods. well anyways where is that sensor located? any pics? well im off to start contemplating parting my baby out. Dang im pissed off. 13000 into this car and it still dont run right.

later thanks again j-rob
 

·
Registered
Joined
·
801 Posts
yeah im interested also

my cars rpms are acting very weird, and i want to change my mlps just in cause.

Marivn M.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #9 ·
the part is 95 dollars at ford. i think they refer to it as a throttle range sensor .
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #10 ·
well i replaced the mlps today and.....squat still having all the problems. any other suggestions? i guess maybe i will save up and buy that new manual valve body that performance automatic makes. god im ready to burn the baby for the insurance money. oh well
 

·
Registered
Joined
·
164 Posts
same boat as you

Hey i know where your coming from, i just got my 3rd tranny put in and its still all funked up. Ford told me they cant cover my bill anymore due to the extensive mods done to my engine, and now this ones goin out. I need to talk to Dennis quick, this is getting very frustrating. If you need someone to buy some parts off ya, keep me in mind

Jesse
 

·
Registered
Joined
·
940 Posts
Make sure you have enough Tranny fluid in there.


Also to 5150Bird: Have you thought about rebuilding your tranny with the level 10 parts.

Just my $.02
 
1 - 12 of 12 Posts
Top