TCCoA Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
Well... I bought the car for 3,8. I spent hundreds of dollars on a new intake manifold, new suspension, and 6 tires(2 got ruined due to balljoints). That all happened in the first 6-8 months. Now I thought I'd be good for a while.... but it seems that at 108, miles the transmission is dying.

Every time I accel it kinda shutters at a gear. If I use cruise control to accel it really gets jerky around 45-50.

I actually was JUST about ready to do performance mods.. but THIS has happened! OMG.

Any suggestions? I love the car, I want to keep it. Should I just buy a transmission from greanleaf.. they sell one at around 430 shipped. I need to go cheap... cause it will take me weeks to get the money anyhow.

Honestly, how much does it cost to get a pro to swap my transmission??
 

·
Registered
Joined
·
604 Posts
could be a number of things. anything from faulty torque converter to a bad plug or two. i had this issue on another car of mine when on the highway it would not change gears and just stutter run rough - turns out i had a bad plug (bosche = terrible) and after changing it for a delco, everything ran great. I would have a shop look at it and diagnose it before assuming its the trans.
 

·
Administrator
Joined
·
8,033 Posts
Have you tried a fluid change? Be sure to drain the torque converter and use Mercon V.

Joe
 

·
Registered
Joined
·
1,742 Posts
whne i bought my 89 3.8 i thought it had a trans problem. turns out it just needed a tune up. just go to town change all the fluids, filters, plugs, wires, you name it! your car will thank you! thats what i did and i had over 300,000 miles on it when i had to part with it.
 

·
Registered
Joined
·
1,170 Posts
Well... I bought the car for 3,8. I spent hundreds of dollars on a new intake manifold, new suspension, and 6 tires(2 got ruined due to balljoints). That all happened in the first 6-8 months. Now I thought I'd be good for a while.... but it seems that at 108, miles the transmission is dying.

Every time I accel it kinda shutters at a gear. If I use cruise control to accel it really gets jerky around 45-50.

I actually was JUST about ready to do performance mods.. but THIS has happened! OMG.

Any suggestions? I love the car, I want to keep it. Should I just buy a transmission from greanleaf.. they sell one at around 430 shipped. I need to go cheap... cause it will take me weeks to get the money anyhow.

Honestly, how much does it cost to get a pro to swap my transmission??
Do your homework on torque converter shutter. This is not the end of the world, frustrating but definately fixable.
 

·
Super Moderator
Joined
·
12,021 Posts
Yea, I'm with these guys. I'd say you've got some TC shutter.

Do what Rodeo Joe said and get yourself a Jmod. You'll thank yourself for it. You're only a 2.5 hours drive from RobertP (He's in Carthage, NC) he can do the Jmod for you and check the car out. If you've got the money I highly recommend upgrading the TC to one of Dirtydog's units.

I don't think you'll need to replace the transmission. Talk to Robert about your options and his prices; he's very reasonable.
The number to his shop is 910-947-7044.
 

·
Registered
Joined
·
5,978 Posts
btw you cant call a 108k 12 year old car a lemon . its a maint. issue at that point
 

·
Registered
Joined
·
83 Posts
Discussion Starter #8
Of course Jk69... I understand that. My dad has bought used cars before.. and never had to put 50% of the price he paid for car into maint. issues. His F150 has had the transmission go at 200K miles. That's decent. That's really the only problem..

Thanks for all advice.. keep it coming =] I just bought some autolite plugs. Going to get motorcraft wires next week... Then I'll see if it helps.. and then I'll think about TC and Jmod.

Thanks guys,
Kevin
 

·
Registered
Joined
·
33 Posts
Mine had the "jerky" issue when I first got it so I pumped out the old fluid thru the tranny cooler (rad) and changed it out for new Mercon V and 4k miles later the "jerkiness" is almost gone..........maybe some Mojo changed it with regular fluid......
 

·
Registered
Joined
·
5,978 Posts
Of course Jk69... I understand that. My dad has bought used cars before.. and never had to put 50% of the price he paid for car into maint. issues. His F150 has had the transmission go at 200K miles. That's decent. That's really the only problem..

Thanks for all advice.. keep it coming =] I just bought some autolite plugs. Going to get motorcraft wires next week... Then I'll see if it helps.. and then I'll think about TC and Jmod.

Thanks guys,
Kevin
return the plugs and get motorcraft
 

·
Registered
Joined
·
83 Posts
Discussion Starter #11
They said they wouldn't have any for WEEKS. I went to napa.. the same plugs were $1.50 more each. I'll use this as a temp fix. I am SURE they are better than plugs that have not been changed after 109k miles.
 

·
Registered
Joined
·
1,170 Posts
Mine had the "jerky" issue when I first got it so I pumped out the old fluid thru the tranny cooler (rad) and changed it out for new Mercon V and 4k miles later the "jerkiness" is almost gone..........maybe some Mojo changed it with regular fluid......
Yes, it definately takes a few hundred miles of driving to make a difference in shudder. The TSB in 1999 said 50 miles but our cars have much more wear and tear on the clutches.
 
1 - 12 of 12 Posts
Top