TCCoA Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
ok, i just bought this car yesterday for 300 bucks, so expecting a little work.. anyways.. was wondering what fuse is for the seats belts? ( the ones that go back and fourth over the front seats... and, when i rev the engine, the volt meter goes alll the way up and the battery light comes on, then it goes off when i let off the gas ( when it goes back to idle ) any ideas would be great.
 

·
Registered
Joined
·
49 Posts
Your volt gauge going up and the battery light coming on when you rev it would most likely be the voltage regulator on your altenator. You can have autozone or some other place test it for free. That would be my number one guess. As for the fuse for the seatbelt, look on the fuse cover, it should have an explanation of what fuses do what.:zmonkey:
 

·
Registered
Joined
·
226 Posts
Discussion Starter #3
I did, doesnt say anything about the seatbelts tho, i'll go double check, thanks for ht info!
 

·
Registered
Joined
·
226 Posts
Discussion Starter #4
Ok, i just drove the care around the block, when i hit 25mph or more, the volt meter goes all teh way up, battery light comes on, and the radio fades out.. that still sound like the alt?
 

·
Registered
Joined
·
1,119 Posts
Go to Autozone or some other parts store and FOR FREE they will test the codes on the car and the codes WILL tell you what is wrong. Don't waist your time guessing.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #6
I'll do that, but as of right now, i dont have tags/ insurance on teh car yet, i'm just trying to find out a few things might be.. either way, if it is the alt, will the alt from a 95 4.6 fit the same?
 

·
Registered
Joined
·
226 Posts
Discussion Starter #7
well i called the autp parts store and they said it sounds like the voltage regulator. so i bought one, was only 20 bucks, i took the old one out, put new one in, when i conencted the battery cable there was a spark, so i disconnected, took out the new regulater and one of the bronze cabled burnt in half.. ( the ones that come off the white thing ) ... why did this happen? please get back to me asap .. and what's the name of the white part thats attached to the regulator. ..
 

·
Registered
Joined
·
1,890 Posts
Did you disconnect the battery terminals before you changed it?
 

·
Registered
Joined
·
226 Posts
Discussion Starter #9
i disconnected the negative, that's what they told me to do at the shop, i said ' not both ' they said it wasnt needed. but it didnt spark until i reconencted the bat
.. hrmm...
 

·
Registered
Joined
·
1,890 Posts
hmm, I know that if you bolt up the wire to the alt with the battery connected it will spark like a ***** (I made that mistake for the first and last time when I was 16 lol) Is every wire goin to the correct place? Sounds like something is either touching or connected to something it shouldnt be.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #11
well, today i said screw it , went to the junkyard, happen to come across a bird they had jut placed down in the morning ( a 91 ) it has a remanufactured napa alt, took it off in less than 10 min, cost me 15 bucks, had them test the alt at advance and it was in perfect working order, put it in car.. and it seems to be working great, volt meter doesnt do it's thing naymore and no lights fading.. so all is well.. now for replacing the damn window motor.. i have the motor already, but it looks like the guy that had it before tried to do it and scred the ' levers ' all up in tehre.. there's one just laying on teh inside of the door....
 

·
Registered
Joined
·
647 Posts
BeasTx said:
well, today i said screw it , went to the junkyard, happen to come across a bird they had jut placed down in the morning ( a 91 ) it has a remanufactured napa alt, took it off in less than 10 min, cost me 15 bucks, had them test the alt at advance and it was in perfect working order, put it in car.. and it seems to be working great, volt meter doesnt do it's thing naymore and no lights fading.. so all is well.. now for replacing the damn window motor.. i have the motor already, but it looks like the guy that had it before tried to do it and scred the ' levers ' all up in tehre.. there's one just laying on teh inside of the door....

$15.00 for a remanufactured alt in perfect condition is one hell of a deal. Consider yourself lucky. My yard here wanted $50.00 for a used alt. Believe it was still stock too.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #13
ya, i've been going there for years, i'm pretty happy about it :) and when i bring back core they give me 10 bucks back. lol
 

·
Registered
Joined
·
958 Posts
one of them good ol' "do you right and keep your business junkyards"! its always good to have one of these, and let me guess, its not a huge yard, but rather just another hole in the wall yard with not as much to pick over, but still better quality..........i got me one of those places i go to and they always have at least 5-7 thunderbirds when i go..........whole shock tower assembly w/ hub assembly was 25 per side......thats a hellofadeal right there i think!!! i was in need of a windshield for my monte carlo and i called a "big yard", and asked if they had any because its a good drive to get there and i didn't wanna waste my time or gas, well anyways the guy on the phone was really rude and lazy, telling me to come look myself....needless to say everytime i go w/ a friend i pay the $1 to get in and now i have a couple extra pwr ant. switches and fog light switches, and also got an abundance of fuses. i guess thats worth my dollar!!! lmfao
 

·
Registered
Joined
·
226 Posts
Discussion Starter #15
lol, that's great.. it's actually a pretty decent size yard.. there was alot of birds.. def more than 10.. there just pretty cool people there. it's caled ' cohper you pull it ' .. on some weekends it's as much **** as you can pull/carry out for 20 bucks.
 
1 - 16 of 16 Posts
Top