TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Hey guys/gals... I'm still new to the forum, so I appologize if this is in the wrong forum...but I need help bad!!

I gotta get this Bird running in 12 hours or I am screwed... its 1:30AM now...

Please help with any input.

Vehicle Info:

1994 Ford Thunderbird
4.6L V8

Problem:

The vehicle was running very well, then... there's fuel but no spark. When vehicle is turned on but not running. A box in the engine compartment, that is located exactly in front of the air box is making a humm and also changes pitch in the noise when it is disturbed/moved. (See pic for reference...)

What is this box?

Any ideas why it won't start now?

Does this box have anything to do with lack of spark?

<a href="http://photobucket.com" target="_blank"><img src="http://i71.photobucket.com/albums/i139/ATurner777/The%20Bird/Picture042.jpg" border="0" alt="Photobucket - Video and Image Hosting"></a>

Real desperate here, gotta get this bird running. Thank you all in advance.

Please reference this same topic with further discussion and troubleshooting. I am still new to the forum and thought I would try this section too, thanks!

http://forums.tccoa.com/showthread.php?t=89025

Andy
 

·
Premium Member
Joined
·
3,247 Posts
There is a duplicate post in the Club forum.

I agree with Sir William to check the crank position sensor.
 

·
Registered
Joined
·
106 Posts
To answer your first question it is called IRCM/CCRM it is a relay control module inside is the eec, fuel pump, wot, and fan control relays. If it is humming then I would check all powers & grounds to it. My guess would be you have a bad ground and the noise is the relays cycling off and on. This could be the cause of your lack of spark.
 
1 - 3 of 3 Posts
Top