TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
OD off light keeps going off and on on its own. when i put it in drive it will rev up then finally grab. once i get up to speed....45-55 and give some gas it won't downshift, and shakes. When I slow down to stop theres no downshift. and when i try to go again it stays in 3rd or 4th unless i manually downshift.
Any Ideas???
 

·
Premium Member
Joined
·
3,247 Posts
The flashing OD light is the tranny's way of telling you something is wrong with it.

A code is being generated that can be obtained with a scan.

If you can, drive it to a Midas, Monroe, or any close-by place that will do a scan for around $20-$30.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #3
Here's a little more info:
I have a shift plus from B&M connected, haven't used it but maybee 5 times since I had the tranny replaced, and only a minute or so each time. It spends most of the time inside the center counsole, and off.
Friday during lunch I opened the counsole to use the cup holder and noticed that it was turned on to the first setting. Thinking nothing of it I turned it off. On the way home after work the problems began as I said above. I just completely disconnected the shift plus from the computer and that had no effect on anything what so ever. So finally I connected my code reader and got codes 622 and 624: Shift solenoid #2 circuit fault, and Electronic Pressure Control solenoid circuit fault.

The only things that I can come up with is that the Shift Plus overheated these solenoids and fried them, especially since I have no idea how long the damn thing has been turned on.

Or the salt from the road got into the harness and corroded some wiring and the shift plus being on at the time was just a coincidence.

I'm kinda leaning towards the first one though:confused:

Please give me your thoughts. And if these solenoids have to be replaced how much would that run me?
 

·
Registered
Joined
·
632 Posts
The shift solenoids come in a pair, SS1 and SS2 is really one unit. Its like $25 or so, so its not expensive. However, you need to make sure that the computer is not whats causing the fault.

-Andrey
 

·
Registered
Joined
·
71 Posts
Discussion Starter #5
a little bit of an update...
Our tranny guy at work knew nothing of ford transmissions, I just got back from the ford dealer and he said it sounds like the valve body. He said he thought that there was a common problem with the valve bodies in our cars. He also said it could possibly be some gunk or something clogged in the valve body and suggested that it be flushed.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #6
What's the deal???
I know there is someone who has an idea here.
 

·
Registered
Joined
·
632 Posts
Here is my idea:

The dealer does not know what he is talking about, and just wants to take your money for the flush. Just like the ford dealer here wanted to replace my differential when my transmission was failing.

Replace the EPC solenoid, and get the codes read again.

-Andrey
 
1 - 7 of 7 Posts
Top