TCCoA Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
2,176 Posts
Discussion Starter · #1 ·
Guy's I just sold my amp and subs to a guy my brother work's with when I installed it one of channels wasn't working. So the dude call's me last night and has me stop by cause the speaker wire's come off the back of the box. I attach them and nothing. I think the other channel blew. Is it possible that the wires touched and blew the channel, or could it have been overloaded with 2 subs on 1 channel??
Does anybody know if it can be fixed and where I should take it??
 

·
Fry Rice Specialist
Joined
·
4,794 Posts
it could be overload with that channel because when you connect the 2 sub in that single channel it change the ohm rating.
 

·
Registered
Joined
·
2,176 Posts
Discussion Starter · #3 ·
That's what I thought. My boy work's at Mickey shorr so I'm gonna see him how much it would cost for the cheapest amp that will run 2 12's.
 

·
Registered
2014 Escape SE 2.0 AWD
Joined
·
7,557 Posts
Man, I bought an Orion 2400D amp for $250 shipped. I'm sure you could get a decent good amp for cheap. I have bought a lot of used equipment from members on carstereos.org, including my current Orion and L7.
 

·
Registered
Joined
·
2,176 Posts
Discussion Starter · #5 ·
Mickey shorr has an amp for $160 1000watt free installation til today I might do that and be done with this dude.
 

·
Registered
Joined
·
2,176 Posts
Discussion Starter · #6 ·
stead of starting a new thread On my cougar when I turn the radio on I get this buzzing. I have bigger spark wires so im thinking that is the cause. How do I get rid of this?
 

·
Registered
Joined
·
2,176 Posts
Discussion Starter · #7 ·
bump read post above!!! need some help!!
 

·
Registered
Joined
·
2,176 Posts
Discussion Starter · #9 ·
the subs from my car are gone and my amp is gone. I still have the rca's sitting there but they go to nothing.
 

·
Registered
Joined
·
2,176 Posts
Discussion Starter · #11 ·
would that have anything to do with the noise since there isn't any sub's back there or could the remote wire from the interior amp have something to do with it.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top