TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6,361 Posts
Discussion Starter #1
This has nothing to do with a Thunderbird...But I need help...

Today my mother took her 1997 Intrepid to the shop because she heard some banging in the front end.....

When I got home from work she told me all of this and said the mechanic told her:

Both, I repeat BOTH front and rear sway bar are bad! How ini the FUC* is this possible, Is there another way for them to go bad besides breaking in half or cracking? Is this possible to happen both at the same time?

Or is the mechanic trying to fu*k my mom?(this is what I think)

I'm gonna go there tomorrow to see the "BAD" sway bars because I can't comprehend how this can happen!

Any input will help!

Thanks Alot

Dave
 

·
Registered
Joined
·
2,662 Posts
Maybe he meant the bushings are bad. I find it hard to believe that the bar itself is bad, unless damaged (bent) in a wreck. Maybe the mechanic worded it wrong. If he sticks to his story, I call BS. never seen a "bad" sway bar unless it was a factory defect. My moms 89 Towncar had a bent front bar that way from the factory, and the dealer always said it was fine. Go figure...
 

·
Johnny Bling Bling
Joined
·
3,811 Posts
dave, if you have some free time, run it down here. i could probably have one of the techs take a quick peek at it for you.
 

·
Registered
Joined
·
2,662 Posts
So what was it??
 

·
Registered
Joined
·
6,361 Posts
Discussion Starter #6
I did not get a chance to see the sway bars before they were "replaced" because of my work schedule, but IF they were replaced they look fine now, I friggin doubt they were bad, I just wish she didn't run to the shop so quick.

Thanks Alot Guys for your input!

Dave
 
1 - 6 of 6 Posts
Top