TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Well I got all the parts together to do the JMOD on my 95 f-150.
Everything was going fine removed the valve body changed the 1-2 accum,
2-3 accum and the od servo. Removed the separator plate from the valve
body and cleaned it with brake cleaner. At this point I started identifying the holes
that needed to be opened up and the sizes. When I got to the #6 and #11 holes
both of these had .100 x approx .38 slots which where the holes s/b. The valve
body was replaced when I had the trans rebuilt so I don’t know if this is the correct
valve body. Should I continue with the JMOD drilling the remaining holes
according to Jerry’s valve body modification article or do I need to replace the
separator plate? If I need to replace the separator plate does anyone know
the part# ?
 

·
Registered
Joined
·
3,178 Posts
If those holes are already larger than what the article recommends, just skip them and go to the next one. At home I have a spare 5.4L 4R70W VB, but I am at school and dont have access to it to verify... and you cant buy just a separator plate, youd have to buy a new valve body to get one.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks silver bird I posted this question on the modular depot site also. They said I
should send winston or sct guy a pm. I sent one to winston and I'm going to send one to sgt guy also. Thanks for the reply.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Thanks for the help so I could complete the JMOD on my F150, I ignored the
#6 and #11 holes as they were slotted (.100x .375) and drilled the remaining holes.
The 1-2 and 2-3 shifts are firm and feel great , but the 3-od shift still seems delayed and I’m still getting some shuddering. The shuddering only seems to occur on hills
when I’m maintaining a constant speed, not under acceleration. The problem is
intermittent and it is much better since the JMOD and Mercon V are in.
Any ideas would be helpful.
The od light is not blinking and no codes are set in ECM mem.
 
1 - 5 of 5 Posts
Top