TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I have had a low idle problem (idles in drive/reverse at 500 RPM) for a long time now and my theory is that the PS pump is so loud and messed up that is actually slowing my idle down when I come to a stop. The fluid used to be Mercon V but is a grayish puke color now and it is VERY loud. It is a rebuilt pump and I ran it dry a couple of times when I didn't know that I had a leak. That couldn't have been good for the pump. I have flushed it several times and tried all different types of fluid so I think it is time again just to change it.

So who makes a new or rebuilt pump that won't make all of the ruckus that this one makes? Changing that pump has to be one of my most dreaded jobs on the SC. Anyone who has done it before knows what I am talking about. Thanks for any info.
 

·
Registered
Joined
·
724 Posts
I would imagine that a rebuilt one would be much quiter. I havea small leak in my 90 but it doesn't really make any noise if I keep it full. I would think that a rebuilt one would work out fine.
 

·
Registered
Joined
·
127 Posts
My original PS pump is still working fine, no noise. 120K in hot and cold city use. Try using a conditioner with the new oil. As for the idle, I would't jump to conclusions. Alsmost every SC I have seen including mine has that problem. I haven't pinpointed it yet and almost seems to be computer related, as all sensors and most parts are new. Warm up the engine then remove all your belts. Shift to D or R. Is it still hesitant?
 

·
Registered
Joined
·
204 Posts
My 90 has a lot more miles and no noise from PS pump and I thing the 500 rpm idle issue is more related to a bad connection or hose in the PCV system than to any computer. I was having the low idle problem and found a hole on the bottom of the hose near the firewall. Then I found the little hose under the intake had come loose behind the AC bracket. Good luck
 

·
Registered
Joined
·
250 Posts
Most Ford pumps, including ours, are designed for and work best with ATF Type F. To back this up read your owners manual. They run quitest on this. It's probably too late for yours but make sure to use it in your new one. Don't let it run dry, especially on intitial startup for the next.

Vernon
 

·
Registered
Joined
·
127 Posts
Vernon,
When I spun off the ps pulley from Lil Red's power steering pump........and then switch it out with the 94.....of course, like we discussed prior too. Anyhow, I didn't realize how good I had it with the one I pulled from my 92. The donor PSP is soooo damn noisey.........the 92 pulled never made a sound. Guess I need to get over Napa and get another PSP, this is one is driving my crazy.

I will be buying one without EVO, and just switch the sensor, just like Stephan did in his Anny back in Sep 03. What did he pay for the one he picked up and what brand, if you can remember. Maybe BIG Man will remember and post since he did the work!

Sorry for the hijack, bigcletus94 !

But listen to Vernon, don't let his post count fool ya.........if you decide to change out the PSP on your own, if not really a bad job once you tearing it down. Keeps us posted on whatcha find!

Good Luck~
Calvin
 
1 - 6 of 6 Posts
Top