TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
521 Posts
Discussion Starter #1
installed new chip and everything works great. but, when you let off the gas i get a little thud or bang in the driveline. another member has the same problem, so it's not just me. anyone have a fix or a explanation for this? thanks.:confused:
 

·
Registered
Joined
·
798 Posts
Check your transmission mount, and/or front differential mounts.
 

·
High-Mileage 4.6L Thrasher
Joined
·
3,232 Posts
It's IRS driveline slop..get used to it. When running the TC locked for efficiency and max HP to the wheels,you'll hear it more than the stock program that has it unlock all the time for the slightest TPS changes.
You can change all of the mounts,and it will help some....but it's a fact of life with IRS.
JL
 

·
Registered
Joined
·
37 Posts
Johnny Langton said:
It's IRS driveline slop..get used to it. When running the TC locked for efficiency and max HP to the wheels,you'll hear it more than the stock program that has it unlock all the time for the slightest TPS changes.
You can change all of the mounts,and it will help some....but it's a fact of life with IRS.
JL
I agree with JL on this one - if it just started with the chip then I doubt anything is really bad.

it's the locking unlocking - I don't think I've ever seen a tbird even with ALL new drivetrain that didn't have some slop in it.
 

·
Registered
Joined
·
521 Posts
Discussion Starter #6
chadr said:


I agree with JL on this one - if it just started with the chip then I doubt anything is really bad.

it's the locking unlocking - I don't think I've ever seen a tbird even with ALL new drivetrain that didn't have some slop in it.
its not hurting anything though is it.
 

·
Registered
Joined
·
798 Posts
I doubt it's hurting anything, you're just hearing the "slop" and play in the driveline.

I changed my motor mounts, U-joints, Front Differential Bushings, and my rear diff mount is definitely stout and i still have some noise. I know the transmission mount is out and replacing it will help some.
 

·
Registered
Joined
·
1,974 Posts
Damn, funny this should come up.
I just got my Diablo (orignally from DR) back from BH, and I was getting the same thunk when I would let off the gas. Never happened with the original tune. I was wondering what was going on, till now :)
 
1 - 8 of 8 Posts
Top