TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
Finally got some good air today, and got a new best in my car. Wound up with a 12.05 @ 115.3 mph on a 1.80 60'. I ran a 12.07 and 12.09 to back it up. I actually trapped 117+ on three different runs on my newest tune, but it is pulling timing right at the beginning of a run which is hurting my 60's. My best on the new tune is a 12.09 @ 117.49 mph, with a 1.85 60'.

Mods: PI motor, MHS Stage II NPI blower cams, SVO blower with 3.3 pulley (8ish pounds of boost), AIS methanol injection (2 7GPH nozzles), 75 mm TB, offroad Prochamber, and 2 chamber Flowmasters, on 275/40-17 Nitto NT555R drag radials. It is on the stock transmission/converter, stock 3.27 rear gears, and the only weight reduction was the spare tire/jack and passenger seat.

Hopefully getting the tune issue sorted out and a set of 3.73s will put it into the 11s. Not bad for a daily driver. :D
 

·
Registered
Joined
·
379 Posts
Good runs and a nice Mustang. It was a pleasure running with you but I'm sorry I do not remember meeting you ??
 

·
Registered
Joined
·
108 Posts
Discussion Starter #5
Thanks guys!

Good runs and a nice Mustang. It was a pleasure running with you but I'm sorry I do not remember meeting you ??
I don't think I ever actually came and spoke to you. I was wearing a red NC State coat. I was hanging around Mr. RobertP and his crowd most of the afternoon.

Good running Mark VIII as well! Sure did make my car look slow, haha.
 
1 - 5 of 5 Posts
Top