TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,278 Posts
Discussion Starter #1
The tranny makes the car a whole 3 sec faster on the 0-60. So I am very happy with it. But it leaks every time I drive it. About a spot the size of a hand ball. But only if the car has a chance to warm up. Never when I just cycle through the gears sitting in my drive way. I check the tranny leval and keep it full. So mechanical failure isn't to likely. But that damn fluid makes a mess and it isn't cheap for MER V. Does any one know what seals or "o" rings need to be new when performing a tranny swap? Or what has leaked when doing the same swap? Thanks...Eric
 

·
Registered
Joined
·
974 Posts
wow 3 second faster on 0-60? how bad was yoru trannie before??
 

·
Registered
Joined
·
615 Posts
I'll just throw some stuff out there. There is a seal for your drive shaft, that could have been ruined when putting the drive shaft in. Also if you put a new TC in you should change the seal behind converter. Thats all I can do for you, put the tranny is a complete rebuild so I don't know why a seal would leak.
 

·
Registered
Joined
·
1,278 Posts
Discussion Starter #4
How bad was it before? Well, put it in terms that I understood. It felt like I had a 3000 stale on my converter. When I read the troubleshooting artical about tranny problem. My old tranny had every problem that it listed. Not to mention it was so hot that if I places my leg agianst the hump, I could feel the heat radiating off the carpet. It was bad...Eric

P.S. The leak I had was from my fill tube. The o ring had severed and was not even there. I still have one drop about the size of a quarter. But I figure I will eventually fine the problem...
 
1 - 4 of 4 Posts
Top