TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi.

Just picked up this lump about a week ago, thought it would be cool to have a V8 semi-hot rod again, don't know what the hell I was thinking, but regardless I own this baby now. '91 5.0 HO btw...And yes, I've fallen in love with it already.
Needs massive suspension work and a few other issues, but overall, seems to be a good car. Clock stopped a few weeks ago at 98,000 miles.

#1)The oil light flickers occassionally while in drive with my foot on the brake.
(The sender and wires are saturated in oil also), so I'm wondering if this has happened to anyone else and if it is something to be concerned about. The light just flickers though, it does not stay on.

#2)The engine bay is filthy. Any issues with powerwashing the engine compartment?
I used to do it all the time when I was a Ford tech (C), but back then these cars were new, and I never had any problems. So is there anything that would need to be protected (other than the obvious components) during a power wash?

#3)Hard starts. After a forum search, I'm pretty sure it's the fuel pump, but not 100% convinced yet. Cranks and cranks if you just try to turn the key to start, eventually, it'll start. Most times...
If I turn the key on/off 5 or 6 times to "prime it", she'll start right up.
Could this possibly be nothing other than it being in need of a massive tuen-up? or do any of you agree with the fuel pump possibility?

#4)Tune-up parts recommendations? Cap, rotor, plugs wire etc? Which brand is best for these cars? it's bone stock, but eventually I'm going up the hp a little bit, pretty much bolt on stuff only, so I'm thinking of something a little performance oriented like MSD, Accel, etc...

Any input would be appreciated.
Thanks!
 

·
Registered
Joined
·
2,662 Posts
Hi.

Just picked up this lump about a week ago, thought it would be cool to have a V8 semi-hot rod again, don't know what the hell I was thinking, but regardless I own this baby now. '91 5.0 HO btw...And yes, I've fallen in love with it already.
Needs massive suspension work and a few other issues, but overall, seems to be a good car. Clock stopped a few weeks ago at 98,000 miles.

#1)The oil light flickers occassionally while in drive with my foot on the brake.
(The sender and wires are saturated in oil also), so I'm wondering if this has happened to anyone else and if it is something to be concerned about. The light just flickers though, it does not stay on.

Check the oil level. If full, clean the sending unit. Had this happen on many 5.0's

#2)The engine bay is filthy. Any issues with powerwashing the engine compartment?
I used to do it all the time when I was a Ford tech (C), but back then these cars were new, and I never had any problems. So is there anything that would need to be protected (other than the obvious components) during a power wash?

Just the electrical stuff, which I'm sure you're well aware of. Never really powerwashed mine though...

#3)Hard starts. After a forum search, I'm pretty sure it's the fuel pump, but not 100% convinced yet. Cranks and cranks if you just try to turn the key to start, eventually, it'll start. Most times...
If I turn the key on/off 5 or 6 times to "prime it", she'll start right up.
Could this possibly be nothing other than it being in need of a massive tuen-up? or do any of you agree with the fuel pump possibility?

Either the fuel pump, or possibly the fuel pressure regualtor. Couldn't hurt to change the fuel filter either if its unknown when it was last done.

#4)Tune-up parts recommendations? Cap, rotor, plugs wire etc? Which brand is best for these cars? it's bone stock, but eventually I'm going up the hp a little bit, pretty much bolt on stuff only, so I'm thinking of something a little performance oriented like MSD, Accel, etc...

For now, I'd stick to good ol Autolite Coppers for plugs, a nice set of 8mm wires, and quality cap/rotor. I tend to stick w/ Motorcraft when possible.

Any input would be appreciated.
Thanks!

Just my .02

Jay
 

·
Registered
Joined
·
336 Posts
I dont power wash mine. I use Green Clean engine cleaner. If its filthy, you might have to do it a few times. Cant help you with the OIL prob, but change all the fluids in the car just as a percaution. And like the previous writer, I use nothing but AUTOLITE as well. New plugs, wires, blah blah blah and a really good tune might solve all the problems. The MSD will cost you an arm and a leg, and unless you plan on massive H/P, there are many better places to spend the money. Fix the suspension problems, maybe all new polyethlene bushings. Check the motor mounts as well, They fail regularly. Always change the fuel filters. A brake upgrade is always a good start with these boats. Look at your finances and base the changes on that. Dont just go right to the HP increases. These cars have other issues that need to be addressed. BTW, change the tranny fluid and filter regularly.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
Thanks for the replies...

I went through most of the obvious stuff in the car, everything seems ok for the most part, other than normal wear and tear. I changed one rocker and a pushrod when I first got it, and did do an oil change. My swaybar endlinks are flopping around like a fish out of water, so that's this weekends project, I've determined this to be most of the clunking from the front. Ball joints checked out ok too, actually, they look like they may possibly been changed at some point. And the shocks are totally shot, and I need p/s outer tie rod.

I agree with the Autolite tune-up stuff, I just wasn't sure if there was anything else out there that performed better, I've been out of the game a little while.
Fuel filter too, know idea when or if it's ever been changed.
I'm gonna try and get the links and tune-up/filter done over the weekend, and then see if the fuel pump is still the culprit.

Thanks again for the replies!
 
1 - 4 of 4 Posts
Top