TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter #1
Went to US41 this week Friday night. Track sucked!! Could not get any traction at all! Car was all over the place. Both lanes, didn't matter witch one. The best I could muster was [email protected] Ran 9 times most were in the 15'[email protected] 100. Same tires as last time I ran and didn't have any problems last time. Ran [email protected] the last time I was there and the temps were in the 90's then. They were 75 Friday.
It's either the track is s**t, I need slicks or I have too much power now? I wanted to see the differance in times with my new exhaust system in. I guess I'll have to wait till next year now?
On a good note I beat a new Ford Lightning Truck and a late 80's Monte Carlo SS(modifed). Even with no traction!:D
 

·
Registered
Joined
·
1,293 Posts
If you were one of the few having traction problems, it was your car. If most were having traction problems, it was the track.
Either way, slicks can only help.
 

·
Registered
Joined
·
159 Posts
Discussion Starter #3
No I wasn't the only one with problems, everone had problems. The Lightning had them too.
 

·
Registered
Joined
·
6,218 Posts
41 has sucked all year, started going downhill last year towards the end of the season, beginning of the season this year nothing changed.

i wont be going back there much til something changes down there.

if your interested you can join us at GLD in union grove wi next saturday
 

·
Registered
Joined
·
159 Posts
Discussion Starter #5
That's a little far to go. We'll see how the weather holds up.
 

·
Registered
Joined
·
169 Posts
US 41 has sucked all year. however, IMO it's better than goin down to IRP. at least on most nights you can make more than one run in 3 hours. :rolleyes:
 
1 - 7 of 7 Posts
Top