TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
327 Posts
Discussion Starter #1
no electrical from the doors back are working the power windows power locks and mirros and all the break lights rear blinkers trunk poper also car wont start fuel pump isn't getting any power and theres nothing wrong with the battery or the large fuse box under the hood is there any main connectors or grounds for the back half of the car
 

·
Registered
Joined
·
654 Posts
Man I wish I could help pinpoint your trouble - The wiring
to the back runs under the kick panels - there are connectors behind the
passenger and drivers side panels maybe something came loose ??

tricky1996 said:
no electrical from the doors back are working the power windows power locks and mirros and all the break lights rear blinkers trunk poper also car wont start fuel pump isn't getting any power and theres nothing wrong with the battery or the large fuse box under the hood is there any main connectors or grounds for the back half of the car
 

·
Registered
Joined
·
327 Posts
Discussion Starter #5
There is a harness that controls everything in the rear. There is a screw that holds the harness together and it also works as a ground. You have to make sure it is screwed in all the way. In my car (96 tbird) you can find it if you move the drivers side seat all the way back and lay on your back on the floorboard and look up. Its a big harness with alot of wires on it and it will have a bronze screw in the middle of it.
 
1 - 5 of 5 Posts
Top