TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,923 Posts
Discussion Starter #1
My parents 1993 Aerostar has been running worse and worse.. and as of today, it hardly runs and even is hard to start..

I'm thinking injector(s) since you can hear them as clear as day, and one is even louder then the rest (more of a `clack' at times).. and when you hold the #6 injector, you can feel the `clacking' like noise..

Anyone know what injectors are used on a '93 4.0L and how hard they'll be to replace them on a '93 Aerostar??

One site said the injectors are the same as the ones on a 5.0L (HO 19# ones)??? which would be cool, since i have a spare 16 of them :rolleyes:
 

·
Trumpeter Extraordinaire
Joined
·
2,917 Posts
www.motorcraft.com -- catalog lists "90TF-AA - (BLACK)" as the injector (CM4681). CM4681 does not cross-reference to any other vehicles in the Buyers Guide on that site.

I have no idea how difficult changing them is, but Autozone.com has the procedure in their online repair manuals, FWIW....
 

·
Registered
Joined
·
1,923 Posts
Discussion Starter #3
thanks for the Reply..


Yah all i know is the ones in are Bosch injectors, where the 5.0L ones are Denso

I still have a Few places i like to call to see for shure.. Else i'm gonna have to rip the Van apart, after checking the Fuel pressure to be 100% shure and if i can get at the damn port, Take the injectors to a shop to have them checked/clean and see what they say..

Mind you i have this slight feeling MAYBE the Van has a Vacuum leak too, since when you yank the plug out of the IAC (which is new), it continues running (Barely, but it does)

A $1000 van at the MOST, and have more then that sunk into it right now :( (OH it recently had the front brakes, T-stat, and other things done too, the running issue happened AFTER all that was done, which is the real p!$$ off part of it)
 
1 - 3 of 3 Posts
Top