TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,747 Posts
Discussion Starter #1
BTW the vehicle is my 1997 jimmy. 4.3l v6, 4x4

I found a new issue that might not be too serious from what i read on other forums from people with the same problems. Anyways the transmission shifts perfectly fine and doesn't slip or anything but once as you floor it the truck hesitates. Its not throwing any codes. I'm starting to think it may not be a tranny issue but a fuel problem or the catalytic converter is clogging. It idles at 500 rpm braking at a stop light, AC off, which is what my cougar did before the fuel pump went out and one of the converters clogged. From what I remember everything just dumps into one converter on these things right? People have said it was as simple as an oil change with the same problems, and I know its overdue. Come payday im gonna go get the tranny flushed cause it needs it and give it an oil change. You can also hear the fuel pump run from outside the truck.

I just dont wanna throw money blindly at it if its something that can be figured out by asking around, ya know lol.
 

·
Registered
Joined
·
1,747 Posts
Discussion Starter #3
yeah i know :(
 

·
Registered
Joined
·
1,747 Posts
Discussion Starter #5
Oh, I forgot to mention that. The previous owner said that one day the truck wouldnt start so he replaced the fuel filter and it started again. Maybe that weakened the pump or the sock on the end of it is clogging, i dont know. At half throttle and every other position except WOT the truck runs excellent. I also cleaned the MAF and that didnt help any. Im probably going to replace the MAP and TPS this weekend. Also Im gonna change the oil and transmission filter.
 

·
Registered
Joined
·
1,747 Posts
Discussion Starter #6
Turned out to be the transmission filter. After ruining a set of clothes and being bathed in transmission fluid its fine now.
 
1 - 6 of 6 Posts
Top