TCCoA Forums banner
1 - 13 of 13 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
94 LX 4r70w. Dash light is flashing. Last time that happened, i had the transmission rebuilt. That was a few years and maybe 10k miles ago. Trans is acting perfectly fine. Shop that rebuilt it states that it may be an incurable electrical issue - having nothing to do with anything mechanically wrong.
Anyone see this same behavior?
Thanks,
Glen
 

· Super Moderator
97 Thunderbird 4.6, 98 Mark VIII LSC
Joined
·
12,542 Posts
Get the code(s) read with a scanner and see what it means.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
SnapOn code scanner reveals code 1732 - 2-3 shift or possible connector issue or possible PCM. I mention SnapOn as Autozone and Advance Auto are not capable of reading the transmission codes (their readers only go back to 96). My local mechanic helped me out.

He states that if it were the PCM, the OD light would come on instantly. In my case, it is taking several miles before the light comes on.
The 2-3 shift seems perfectly fine so it doesn't appear to be a bad solenoid.
Guessing this is a wiring/connector issue and will continue to investigate.
 

· Super Moderator
Joined
·
14,607 Posts
Id bet the trans is slipping in 3rd too much for the pcm. It's not seeing the shift as complete. The early ones are the most problematic. If it's running ok, I'd datalog it, monitoring both trans sensors; if they change ratio, it's slipping.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Wouldn't I feel it slipping? Car seems to run and shift fine. Both auto and manual shifts are crisp.
Again, transmission was rebuilt not too many miles ago.
If you monitor both Trans sensors and they don't change ratio, then what?
 

· Super Moderator
Joined
·
14,607 Posts
Datalog it, and see what it tells you. If it's a stuck solenoid or wire shorted, it will show up.
 

· Super Moderator
Joined
·
14,607 Posts
I'm not trying to be a dick,( for once, lol.); that's just what I have to do to figure out what the deal is.
At least I didn't tell you my standard answer:swap it for a rebuilt j-modded 20002 4r70w. That's more complicated than the 96-97 cars. Search for a swap thread, all the details are here.
 

· Super Moderator
97 Thunderbird 4.6, 98 Mark VIII LSC
Joined
·
12,542 Posts
Swapping in a newer trans is the same process for any 94-97. If you wanted to upgrade a 94-95, it's more involved than if you started with a 96-97 as several incremental upgrades were made with the start of the 96 MY.
 

· Super Moderator
Joined
·
14,607 Posts
The solenoids on the 94-95 cars are different than the later ones.
 

· Registered
Joined
·
168 Posts
I had a similar issue a few years ago, where the O/D light would randomly flash on/off and the O/D would only work when it felt like it, whenever I hit the button.
One day, I pulled off the center console to do some other work and found that the O/D electrical connectors that came together under the console weren't properly & tightly snapped together.
The connectors were loosely slipped into each other, so they'd randomly make a connection when driving over bumps or whatever.
I snapped the two connectors together firmly...and never had the problem again. And O/D now works whenever I hit the button.

Don't know if that's your issue, but thought it might be worth sharing my $0.02.
 
1 - 13 of 13 Posts
Top