TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5,430 Posts
Discussion Starter · #1 ·
When I press on the pedal it feels fine, not to stiff, not spongy, but when I'm driving 45mph or so and need to stop it feels like they don't engage and stop the car properly and if I press any harder they just lock up and I skid....Any Idea's?

Also I do not have ABS, my brake booster is fairly new, master cylinder is fairly new, and the brakes have been bled, I'm also using duralast rotors and duralast gold pads from autozone.... only because for whatever dumb reason they have a lifetime guaranty and replace them when I complain :D..... Is this possibly just really bad brake fade? Should I upgrade to some drilled and slotted or drilled or slotted rotors? Any feed back is deeply appreciated.
 

·
Registered
Joined
·
2,233 Posts
Chris_Murder said:
Is this possibly just really bad brake fade? Should I upgrade to some drilled and slotted or drilled or slotted rotors? Any feed back is deeply appreciated.
It's not fade. If you used the brakes enough to heat them up and get pad fade, they wouldn't be locking up. And drilled and/or slotted rotors will do nothing but look blingy.

When they lock up, are you using a lot of pressure, or a normal pressure that shouldn't lock them up? Which tires are locking up?

My first guess is that the pads are contaminated with something. But without looking at it in person, I won't be a lot of help.
 

·
Registered
Joined
·
5,430 Posts
Discussion Starter · #4 ·
I'm using no more than normal pressure that shouldn't cause them to lock up so easily, its definately the back wheels that lock before the fronts but they all do lock easily
 

·
Registered
Joined
·
5,430 Posts
Discussion Starter · #5 ·
also they sound like worn brakes already, and all of the pads and rotors were changed probably about november-ish, it sounds like a squeeling, not at all like a grinding, just noisy, lofty, and locky
 
1 - 5 of 5 Posts
Top