TCCoA Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
I've had this odd clunking sound for a while now. I have had UCA's and LCA's on the both sides replaced. The right side was Ford, the left was Moog. I think the clunk is coming from the driver's side, but I'm not 100%. The recording was taken on my phone (sorry) while it was laying in the floorboard under my feet. The recording is a little muffled, so the real sound is a little more like a rattle. Any ideas?

http://www.youtube.com/watch?v=frgU5YvNDYc
 

·
Premium Member
Joined
·
5,862 Posts

·
PostSlut
Joined
·
13,597 Posts
ehh, sounds like a bunch crap rolling around..
 

·
Registered
Joined
·
4,407 Posts
How do you guys determine the Sway bar links without the car actually being driven???
 

·
Registered
Joined
·
4,407 Posts
its called an imagination!



:tongue:
I suppose. Unless its just a recording of the noise with a still shot of the car in it.

EDIT: Should have actually read the post from the OP. oh well.
 

·
̇
Joined
·
3,701 Posts
Sounds like a broken rear sway bar link..could be either side...




Rayo...
 

·
Premium Member
Joined
·
5,862 Posts
I suppose. Unless its just a recording of the noise with a still shot of the car in it.

EIT: Should have actually read the post from the OP. oh well.
Yes, I did ASSUME (I know what it spells) it was just a still he put on the post, but the recording was done with the car moving. Didn't he say he had the phone on the floor recording?
 

·
Registered
Joined
·
4,407 Posts
Yes, I did ASSUME (I know what it spells) it was just a still he put on the post, but the recording was done with the car moving. Didn't he say he had the phone on the floor recording?
:rolleyes: Read the Edit.
 

·
Premium Member
Joined
·
5,862 Posts
:rolleyes: Read the Edit.
Oh, I see. So again I was supposed to ASSUME that you meant with this comment what the OP meant (he didn't really state he was moving, so you ASSUMED too).

I'm just saying :zdunno: :D
 

·
Registered
Joined
·
4,407 Posts
Oh, I see. So again I was supposed to ASSUME that you meant with this comment what the OP meant (he didn't really state he was moving, so you ASSUMED too).

I'm just saying :zdunno: :D
ok are you gonna follow me around the boards? Take your instigating bullsh!t somewhere else gramps
 

·
Premium Member
Joined
·
5,862 Posts
ok are you gonna follow me around the boards? Take your instigating bullsh!t somewhere else gramps
I'm hope you're just messin' around, cause I wasn't trying to offend you in the least. Maybe you should go get you some.....
 

·
Registered
Joined
·
4,407 Posts
Giving your track record regarding what I post, Yeah. And at least mine is still working.
 

·
Registered
Joined
·
1,573 Posts
GETTING BACK ON TOPIC.............

It definately sounds like a endlink. You just need to determine wether the sound is coming from the front or rear. From the vid it sounds like the rear ones. I replaced both fromt and rear at different times chasing down that clunk. Do yourself a favor though and get a GOOD set of links. I bought Raybestos ones from Rockauto and 3 months/1K miles later they are still good where the others lasted me maybe 1 month before making noise again.
 

·
Premium Member
Joined
·
5,862 Posts
Giving your track record regarding what I post, Yeah. And at least mine is still working.
That's an ugly rumor. And those little blue pills I take are for my sinuses! :eek:
 

·
Registered
Joined
·
4,407 Posts
To the OP, bad front links I always found to be more of a rattle. Rears were a hard clunk. Either way its still hard to diagnose through a video of sound. Do what I did. By all 4 links as preventive maintenance. They are fairly inexpensive and you'll be happy to know all the links are completely out of question. Good luck.
 

·
PostSlut
Joined
·
13,597 Posts
you know, if you are afraid to spend the money, then just unhook or remove all 4 links, and see if the noise goes away.
 

·
Registered
Joined
·
4,407 Posts
you know, if you are afraid to spend the money, then just unhook or remove all 4 links, and see if the noise goes away.
Yeah that'll definitely be a good way to find out. Hopefully he wouldn't drive it like that tho. I drove JustinH's vortech bird with no links front or rear and oh man I was getting sea sickness in the turns.
 

·
PostSlut
Joined
·
13,597 Posts
Yeah that'll definitely be a good way to find out. Hopefully he wouldn't drive it like that tho. I drove JustinH's vortech bird with no links front or rear and oh man I was getting sea sickness in the turns.
try driving the 73 bird...or my 98 lesabre....ugh, no handling FTW!

My 95 is okay....I only run a rear sway bar...no front. I also run skinnies up front with no pwer on the power rack......
 
1 - 20 of 23 Posts
Top