TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
508 Posts
Discussion Starter #1
Ok, I repleaced my wires and plugs 2 months ago, new battery last week, car still runs like poop. I start her up, RPM's drop to 500 then she stops running all together. Hmmmm ok, start her up again, give it some gas and hold the RPM's at 2k for 5 seconds, let off and she is fine. Sometimes trying to get up to speed she tends to shutter a little bit.

A while ago a mechanic sprayed some carb cleaner in the intake as it was having trouble idling, should I try this and see?


Thanks!
 

·
Registered
Joined
·
573 Posts
If you want to keep the car I would start with a new PCV valve, EGR valve, IAC valve, TPS sensor and the air filter. At the same time replace the hoses. Blow some electrical cleaner on the MAF sensor too. Also, push the fuel injector connections on. One might be loose. Then make sure all the plug wires are on right and tight.
 

·
Registered
Joined
·
508 Posts
Discussion Starter #3
If you want to keep the car I would start with a new PCV valve, EGR valve, IAC valve, TPS sensor and the air filter. At the same time replace the hoses. Blow some electrical cleaner on the MAF sensor too. Also, push the fuel injector connections on. One might be loose. Then make sure all the plug wires are on right and tight.


Dare I ask what the sensors will run?

If I hook it up to a scanner will it tell me what is wrong if it is a sensor?

I have a K&N Panel Filter, cleaned it a little bit ago, checked all the FI wires and the plug wires are secure.

Thanks for the quick response!;)
 

·
Registered
Joined
·
2,662 Posts
Try the IAC and cleaning the MAF. Solved the same issue on my 95. And since you have a K&N filter, I would def. clean the MAF, as the oil from the filter can cause issues.

Jay
 

·
Registered
Joined
·
508 Posts
Discussion Starter #5
Try the IAC and cleaning the MAF. Solved the same issue on my 95. And since you have a K&N filter, I would def. clean the MAF, as the oil from the filter can cause issues.

Jay

How much is that IAC, what is it, and where is it located?

Thanks
 

·
Newbie
Joined
·
5,650 Posts
The IAC will run ~50 bucks. It's located in a horrible place on your early 4.6L. From the driver's side of the engine look down on the intake before the throttle body and it's there. There are pictures of it in a thread here. Might want to search and see what you get.
 
1 - 6 of 6 Posts
Top