TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Well I bought my ride about a year ago and I've noticed lately that my oil has been missing. There are no visible leaks anywhere, even when it has been driven for the whole day and parked for a while in my driveway, the only thing that I did notice is that I found oil in the coolant container. I need help, would like to fix asap before it gets any worse or is this as worse that it can get? All help is appreciated thanx
 

·
Registered
Joined
·
1,196 Posts
Just a guess, but having oil in the coolant is probably not a very good thing. Usually when a head gasket goes, you will get coolant in the oil. But maybe that works the other way too. Possibly a small crack in the block, letting oil seep out into the coolant. Just some guesses.

Joe
 

·
Moderator
Joined
·
8,239 Posts
flush the coolant system and see if it comes back. You are probably seeing rust in the overflow bottle if your system has not been maintained properly.

As for the oil leak, its mostly valve seals. Just keep the oil level up and it will run forever. Literally forever.

What oil weight and brand are you running?

10w30 is about as thick as I would go with tbird mod motor.

JH
 

·
Registered
Joined
·
748 Posts
Normally.......you'll find coolant in the oil if a head gasket blew..........but there are times that a head gasket will blow in the right place so you end up getting oil in the coolant. Like suggested above........flush the coolant system and check and see if it comes back. I'm more apt to think it's valve seals though...........
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
The brand of oil that I use is Pensoil and the weight is 10w 30. I'll do the coolant flush on the car and i'll get back on this thanx y'all.
 
1 - 6 of 6 Posts
Top