TCCoA Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
250 Posts
I can't see 1/2qt over causing this, but it wouldn't be a bad idea to bring it down to "normal" level to see if it helps. The pcv valve is the only possible thing I could think of. Even then the engine creates vaccum that suck air up the tube so oil flowing back down is...odd. Is it pure oil that is a defined stream down the intake or does it have a splatter look? Your air filter; is it a k&n or factory? Is the oil for sure motor oil? look? smell?
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #5 ·
Stinkfist04 said:
I can't see 1/2qt over causing this, but it wouldn't be a bad idea to bring it down to "normal" level to see if it helps. The pcv valve is the only possible thing I could think of. Even then the engine creates vaccum that suck air up the tube so oil flowing back down is...odd. Is it pure oil that is a defined stream down the intake or does it have a splatter look? Your air filter; is it a k&n or factory? Is the oil for sure motor oil? look? smell?


Filter is factory and it looked like a defined stream.
 

·
Registered
Joined
·
250 Posts
hmm.. i'm stumped myself. someone else may have a better guess..lol. did it start doing this out of the blue or was it after some sort of incident that you noticed it?
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #7 ·
Just out of the blue. I just put the motor in the car 2 weeks ago. I have changed the oil and put in the correct ammount of oil and cleaned all the oil out of the intake and it seems to have fixed the problem.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #8 ·
What about the tube comming from the vent on the drivers side valve cover to the intake tube? Could it be sucking oil from the valve cover? Is there a difference in the valve covers on a 96 from a 95? Cause I switched from the 95 style to the 96 style.
 

·
Registered
Joined
·
250 Posts
I wouldn't know if there's any differences between 95 and 96, there wasn't any differences between a 97 and 02 cover .. you could pull the tube off and see if any oil is in it. but if it's not doing it anymore than don't sweat it. just keep an eye on the oil level and make sure you're not loosing any.
 

·
Registered
Joined
·
5,430 Posts
the only reason I can think is pcv are you sure you have a good one? that is so odd..... you don't have any vacuum leaks do you?
 

·
Registered
Joined
·
3,180 Posts
The new PCV I bought didn't seal completely, when I checked the 85K OEM motorcraft one it was still sealing tight as a drum so I took the POS parts store crap back and kept the original. I was replacing vacuum lines at the time and thought may as well replace the PCV too.

I would think if you have oil running down the intake tube to the filter it must be leaking it when the engine is off? does the the top of the intake tube look oily too? more so, less?
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #15 · (Edited)
It did till I cleaned it off lastnight but then this afternoon when I looked again it was all oily again. Should I put the old PCV back in and see if it hppens again? I have a couple of pics.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #16 ·
<a href="http://photobucket.com/" target="_blank"><img src="http://i39.photobucket.com/albums/e192/Ncryoten/Motor002.jpg" border="0" alt="Photobucket - Video and Image Hosting"></a>

<a href="http://photobucket.com/" target="_blank"><img src="http://i39.photobucket.com/albums/e192/Ncryoten/Motor003.jpg" border="0" alt="Photobucket - Video and Image Hosting"></a>


<a href="http://photobucket.com/" target="_blank"><img src="http://i39.photobucket.com/albums/e192/Ncryoten/Motor004.jpg" border="0" alt="Photobucket - Video and Image Hosting"></a>
 

·
Banned
Joined
·
2,009 Posts
The PCV system is defiantly failing.



All the hoses coming in and out of the engine should be inspected and cleaned. Get a new valve just in case. Something is plugged up!!! :confused:
 

·
Super Moderator
Joined
·
11,175 Posts
The last time that happened to me...

It was a broken ring, making a bunch of backpressure, and blowing all the oil out. (83 firebird)

Something plugging the drain back holes inside the valve cover could do that too.

How fast is it pumping out?
 

·
Registered
Joined
·
159 Posts
Check to see if there is vacuum to the PVC valve,, just pull the hose off the PVC valve,check for vacuum, then follow the hose to the other endand pull it off and see if there is vacuum,, have seen them clog up at the intake manifold..
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #20 ·
Brand new motorcraft PCV valve, and have vaccum to the PCV valve. I just dunno where all the oil is comming from.
 
1 - 20 of 24 Posts
Top