TCCoA Forums banner

1 - 20 of 28 Posts

·
Registered
Joined
·
371 Posts
Discussion Starter #1
ok this morning when i started my car up the idel was a little weird and then my check engine light came on for like 3 minutes maybe longer,,,,,anyways...ok now when i put my car in reverse it will shake real bad and my rpms drop real low so i tap the gas and it quits acting up for a few seconds.....but when i start driving my car and it starts to warm up it doesnt act up at all and the engine light goes off....what is causeing this problem?? to mee it seems like something to do with my temp sending unit or my coolant temp sensor???? you think???...im lost...it seem like when i start my car something is telling my compuer in my car that my car is already warmed up when its not cause it acts fine when my temp goes up and my temp gauges starts working????....im probably confusing you gusy but i dont really know how to word thjis stuff right sorry....but hopefully someone will be able to help!!

thanks guys
Jay

SOOP!!!! where are you!!!...haha
 

·
Registered
Joined
·
371 Posts
Discussion Starter #2
also forgot to add..its a 91 3.8L non sc

incase you guys needed to know


Jay
 

·
Registered
Joined
·
371 Posts
Discussion Starter #4
yes sounds very similar!!....but i have already replaced my EGR and TPS...not to long ago....so imthinkin it has something to do with my temp sending unit or coolant temo sensor?? could these 2 thing cause my problems?...i dont really know what it is man....im sure you alreay know by now i am a complete dumb*** when it comes to the motor problems! HAHA


thanks
Jay
 

·
Registered
Joined
·
538 Posts
Ok

First Thing, Do you have power brakes? How do your brakes feel when you step on them? If you have power brakes...you may have a vaccuum leak in your power brake booster....Check it out.

BeirutsFinest
 

·
Registered
Joined
·
371 Posts
Discussion Starter #7
does my car have a DPFE???...if so where is it loctad at o my car.


91 3.8L

thanks
Jay
 

·
Registered
Joined
·
2,894 Posts
It is part of your EGR system. In very brief terms, it provides added feedback on vacuum to the EEC. It's kind of a check on the EGR. I have one on my 92 and you should as well. The best description is in the thread. I'd just be repeating it in different words.

A more complex description is here . It contains a drawing which helps visualise what it does.

If I have a pic of it somewhere, I'll post for you.
 

·
Registered
Joined
·
371 Posts
Discussion Starter #9
ok now what is a EVR solenoid???? and what does it do and where is it located??


thanks again
Jay
 

·
Registered
Joined
·
371 Posts
Discussion Starter #10
so i will be able to see and get to this DPFE from the top of my car i wont have to get under it???.....


Jay
 

·
Registered
Joined
·
2,894 Posts
I think that what was meant was EGR. Typo maybe?

Here's some pics straight from Haynes. Lovely book. I was just admiring my PFE today as a matter of fact.;)

Edit: Oops, yeah it is accessed from the top, close to the TB and EGR.




The EGR solenoid is on the firewall. When you are looking into the engine bay from the front, it is almost to the far left end of the firewall, further left than the PFE and has a small circular top. that's the best that I can describe. It has wires running from it to the wiring harness to the left of it. Does that help?
 

·
Registered
Joined
·
371 Posts
Discussion Starter #12
yeah it helps a little bit man......so what is the difference between a EGR valve and a EGR solenoid????....and i know wwhat and where my EGR valve is.....now do you have a pic of the EGR solenoid???....sorry man im sure your hating me by now!


jay
 

·
Registered
Joined
·
2,894 Posts
JuicedByrd91 said:
yeah it helps a little bit man......so what is the difference between a EGR valve and a EGR solenoid????....and i know wwhat and where my EGR valve is.....now do you have a pic of the EGR solenoid???....sorry man im sure your hating me by now!


jay
Not a problem. It takes a command from the computer to regulate the vacuum flow in the EGR. With all this solenoid/valve/transducer/sensor bs, you can see how it can get a little confusing to diagnose. If you think about it all logically and how each component works together, then you can start to se how one thing failing can cause certain problem(s).

Sorry, the solenoid is kind of a vertical cylinder to the left on the firewall, maybe 6inches or so from the EGR. I can't actually measure it just now. Just have a check of the firewall.
 

·
Registered
Joined
·
371 Posts
Discussion Starter #16
well soop

i looked at my motor today and i checked out my PFE sensor...and it was melted on my EGR valve!!!...so i had a spare one from my old motor and i put it on and then my engine light just stayed on and nevr went off it use to just come on and go off every now and then.....so i went to auto zone and they ran my codes and i got code 327...which is my PFE sensor....so thats what i am gonna replace with a new one...so could my PFE be causeing all my problems....like i said in my first post on here??


thanks
JAY
 

·
Registered
Joined
·
371 Posts
Discussion Starter #18
yes i think everyone knows i am a cheap bast***!!!...:D haha but oh well whatever works man.

ill replace it and tell you guys what happens hope fully thats all i will have to replace.


thanks
Jay
 

·
Registered
Joined
·
371 Posts
Discussion Starter #19
or maybe i should just buy a honda???? what you guys think???



HAHAHA just kidding!


Jay:p
 
1 - 20 of 28 Posts
Top