TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
I hit a drift the other day and got sucked in a ditch. I plowed about 4-5 feet of snow for approx. 50 ft. as i was sittin there waiting for the tractor to pull me out my car started to overheat. the next day i got a used radiator fan but it still overheats. when i first got stuck i got out in the over-knee-deep snow to open my hood to make sure everything looked okay and between the fan and the engine was packed with snow. I havent seen or heard my fan engage once since that night. someone said it might be the relay but i have no clue what they're talkin about. if you might know what is wrong could you please let me know what you think it might be and where it would be located?? thanks....cavy
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
Open the underhood fuse box I bet you blew the fan fuse from an overload when it couldn't turn.
 

·
Registered
Joined
·
2,577 Posts
Drift??? Snow??? Over knee-deep???

These words seem to trigger some vague memories... There's something way back there somewhere, but I can't quite bring them up....

Wait a minute.... I seem to associate the words, "snow days", "sleigh riding", "skiing" and "ice skating"... gee that sounds like fun to me......

Probably "selective recall."
 

·
Registered
Joined
·
2,577 Posts
We don't need any more visitors down here....

Actually everybody.. the weather really sux down here this time of year.... just monotonous as heck....


Just say "no" to snow-birds.....
 

·
Banned
Joined
·
2,009 Posts
You guys need some real Cats down there. A puma is not a real cat it is just a kitty! :D

If it was not such a hot and balmy 40 degrees up here I would be inclined to visit all my buddies down south. It has been a while since I went belly surfing in Jacksonville, visited the crocks in the everglades, drank beers around the world in Orlando, scooped up shrimp off the keys bridge or checked out the babes at Clearwater beach. Lucky it is warm up here. ;-0
 

·
Registered
Joined
·
142 Posts
Discussion Starter #7
it was the fuse. i replaced it and the fan worked fine for a week. yesterday i noticed my car was gettin warm so i checked the fuse under the hood. it was blown and the sides of it were melted to the box......any ideas????
 

·
The Parts Guy
Joined
·
7,307 Posts
Cavy,

I have the same thing happen to my 94 LX about once every six months. That is about how often I have to change my fan fuse due to it melting. I'm very interested in a solution, so I'm subscribing to this post.

-Rod
 

·
Registered
Joined
·
59 Posts
i have a 94 lx mine melted so bad i had to run a new wire from the battery with a fuse init to the relay box it started the same way i got ice stuck in the fan one thine and it was all down hill from there i dunno it woks fine now though
 
1 - 9 of 9 Posts
Top