TCCoA Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
i dont know y my car is overheating its not the hoses,thermo.,radiator,headgasketor cracked block or anything like that...so what could it be my timing is off a little i took it round the block burning the tires at each stop n it was boiling by the time i got back....so please dropp some mechanical insites
thanks
 

·
Registered
Joined
·
466 Posts
Are you sure the thermostat is the correct one and is working correctly? Checked on the waterpump? Freshly flushed radiator with all new high quality coolant? Using that pos Dexcool orange/red color coolant, if so that is possibly a reason. Is there enough coolant(common sence, better ask though) Is your fan in decient condition?

Theres lots of possibal things that would be the problem, But if its overheating alot, and youre driving it light that, be prepared to pull the heads to clean out the coolant that comes from a blown HG....

if its none of those, then I'm sure someone will come behind me, and help more.
 

·
Registered
Joined
·
814 Posts
jlee313 said:
i dont know y my car is overheating its not the hoses,thermo.,radiator,headgasketor cracked block or anything like that...so what could it be my timing is off a little i took it round the block burning the tires at each stop n it was boiling by the time i got back....so please dropp some mechanical insites
thanks
We need a little more info to help you. Did you work on it recently? not likely the timing. Boiling how? Overflowing? Electric fan kicking on?
 

·
Registered
Joined
·
66 Posts
Discussion Starter #4
oh i have a 90 so its a pully fan ive checket the radiator its fine the thermo is gone so iits not stickin the waterpump isnt leakin or making a squeeling sound hoses are changed fan clutch is new fan is in great shape not a h.g the engine is fine jus rebuild not even 50 miles on it im going crazy............cant figure it out i might even take it to the shop yea im going to pay someone to work on my car that sux thanx 4 ur help..............
 

·
Registered
Joined
·
814 Posts
jlee313 said:
oh i have a 90 so its a pully fan ive checket the radiator its fine the thermo is gone so iits not stickin the waterpump isnt leakin or making a squeeling sound hoses are changed fan clutch is new fan is in great shape not a h.g the engine is fine jus rebuild not even 50 miles on it im going crazy............cant figure it out i might even take it to the shop yea im going to pay someone to work on my car that sux thanx 4 ur help..............
If the motor is that new could be tight and just needs to brake in. I would heatcycle it a few times and see if it helps. On the timing note, If the timeing was way out front it would make it lean which would run hot. Good luck.
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
How do you know its running hot? Because the gauge says so? Maybe the gauge sending unit is broken like AEDM8 had a problem with.

If its that new of a motor, maybe they didnt torque the head bolts properly and its leaking already. You could try doing a compression check to see if the headgaskets sealed correctly.

-Thomas
 

·
Registered
Joined
·
814 Posts
Thomas said:
How do you know its running hot? Because the gauge says so? Maybe the gauge sending unit is broken like AEDM8 had a problem with.

If its that new of a motor, maybe they didnt torque the head bolts properly and its leaking already. You could try doing a compression check to see if the headgaskets sealed correctly.

-Thomas
I think it boiled over.
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
yikes. And there's no thermostat installed? Have you tried flushing the system? Did a shop repair the hg's for you? Sounds like someone messed up the hg job.
-Thomas
 

·
Registered
Joined
·
66 Posts
Discussion Starter #10
i guess its guess its going to the shop ............my uncle n i dide the rebuild and the h.g. were done properly also the head bolts were torqued to specs but ino after a while u need to re-torque but it hasnt been nearly long enough.....well thanks ne-ways for the help...........
 
1 - 12 of 12 Posts
Top