TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
917 Posts
Discussion Starter #1
I have been getting these codes for about a week now they are rich conditions on both banks. I have a spare PCM and a complete PI intake which should i try first to see it it resolves the problem (or should i do both??). I have cleared the codes a few times and the CEL comes right back on.... I was thinking it was sticking injectors but both banks?? The only thing ive done recently is to swap PCM's from my parts car to utilize the Xcal 2 which i never uploaded the tunes could the refrence of the pcm codes be the problem or maybe the 96 and 97 year differences??? help me out that light is getting on my nerves

THanks

Edit: dont know if it matters but car has 136K on it at present
 

·
Registered
Joined
·
917 Posts
Discussion Starter #3
i think im going to swap out the PCM's that tune was gonna grenade my stock trans if i didnt take it off... i bet those bastards at sct designed this to happen! :zdevil:
 

·
Registered
Joined
·
917 Posts
Discussion Starter #5
i did fix it i put in my untainted stock pcm

EDIT: [creepy old lady by the river voice] its tainted! [/goofy]
 

·
Baddest N/A NPI in Canada
Joined
·
2,118 Posts
Did you check your 02 Sensors?
 

·
Registered
Joined
·
917 Posts
Discussion Starter #7
the code has been gone for about 500 miles on the current pcm with no cel.
 

·
Newbie
Joined
·
5,650 Posts
Unless my PCM is going, how do you know when the PCM is bad or starting to go bad?
In some cases it will throw a code indicated the internal memory or flash is fubar, but more often than not it's the process of elimination. Logging the data from the PCM helps to see if things look right, and if you can verify that the sensors and wiring are OK but the data isn't, the PCM is probably shot.
 

·
Baddest N/A NPI in Canada
Joined
·
2,118 Posts
the code has been gone for about 500 miles on the current pcm with no cel.
I used to have these codes come intermittently, sometimes upto 3500 kilometers apart. They didn't go away until I did my Kooks install with new 02 sensors.
 
1 - 10 of 10 Posts
Top