TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
My friend's mom's Mercedes Benz C220 is throwing the P0411 code. Its secondary air injection system> incorrect flow detected. Any ideas on what this means and how I can fix it???????
 

·
Super Moderator
Joined
·
7,490 Posts
I think the benz uses an electric smog pump. Maybe the motor is burnt out or you have a wiring problem or there is a leak in the system somewhere, or maybe it sucked up some water and damaged something. You have to look at the smog pump system and check all of those things to know for sure.

Mike
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
i knew it was something somewhat complicated, have you ever seen the inside engine compartment on one of these thing? its like a tuna can in there. and all the forums i checked out required membedrship to comment, and i couldn't find any answers to it they just told me what the code meant not how to fix it.
 

·
Super Moderator
Joined
·
7,490 Posts
Well you're not going to be able to fix it without opening that tuna can of an engine compartment up a little. Start by checking the belt routing to make sure it is an electric smog pump. If it is, then check the fuse for it. If that is good, find where the pump is and dig it out and check to see if you have power and ground at the connector with the engine running. If that checks out, plug it in and see if the pump actually runs. If it does, start looking for holes, kinks, etc in the hoses coming out of the pump. Just cause its a benz doesn't mean it's any different to work on, it just means parts will be more expensive. Good luck.

Mike
 

·
Registered
Joined
·
42 Posts
Discussion Starter #6
would you know fo the general location of this pump, this is the first time i've ever heard of it and worked on this car. lol This cars throttle response absolutely sucks, don't know how she drives it.
 
1 - 6 of 6 Posts
Top