TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter #1
I did it, it's my fault. Now that's out of the way earlier today I pulled into a parking space with one of those concrete wheel stops that are held in place by a piece of re-bar hammered through holes in the stops and into the asphalt. Well the re-bar on the drivers side was sticking up and I did not see it. As I tried to back out before I could stop it caught my lower valance and tore half of it off the car. Even broke the center support. I had to go to the hardware store to buy a small c-clamp so after I bent the plastic back in place it would not drag on the road going home. The plastic plugs are still there, it tore the holes in the valance where the plugs go through. Anybody know how to reattach the valance, nuts&bolts with washers? If I bought a new one it would have to be painted and installed proffesionally. Thanks to all,
Richard. :(
 

·
Moderator
Joined
·
8,239 Posts
On my 94 I used zip strip ties. It was broken in a couple places when I bought it. I eventually put a new front bumper on it.

I just did this two weeks ago when I was in AZ I hit a parking curb thing with a 04 neon. It made the loudest sound, but luckily I didn't break the rental car.

JH
 

·
Registered
Joined
·
7,062 Posts
Richard Dalkranian said:
I did it, it's my fault. Now that's out of the way earlier today I pulled into a parking space with one of those concrete wheel stops that are held in place by a piece of re-bar hammered through holes in the stops and into the asphalt. Well the re-bar on the drivers side was sticking up and I did not see it. As I tried to back out before I could stop it caught my lower valance and tore half of it off the car. Even broke the center support. I had to go to the hardware store to buy a small c-clamp so after I bent the plastic back in place it would not drag on the road going home. The plastic plugs are still there, it tore the holes in the valance where the plugs go through. Anybody know how to reattach the valance, nuts&bolts with washers? If I bought a new one it would have to be painted and installed proffesionally. Thanks to all,
Richard. :(
Wow I only thought I did this.......
Did it catch and you think for some reason reverse wasn't working. I was pi??ed. It didn't rip mine as bad as it sounds like yours got it.
 
1 - 4 of 4 Posts
Top