TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,638 Posts
Discussion Starter #1 (Edited)
I just got my first digital camera so I thought that I would give it a go. Here are the parts I have collected for my '02 Explorer swap.

First is the motor, detailed with new fuel rail, injector o-rings, solid motor mounts, and '95 T-bird belt drive. Of course, I couldn't resist the classic Ford blue paint.





Ford Racing Performance 3.73 Trac-Loc aluminum pumpkin. (Thanks to Dan the Man)


Dual circuit cooler for transmission and engine oil


And of course, the old '95 4.6


Some parts not shown but acquired:
oil filter relocation kit
J-mod parts including deep sump pan (thanks to Dan the Man)
'96/'97 fuel lines (thanks to Dan the Man)
Marauder torque converter

Still waiting to receive my '93 MKVIII driveshaft.
Exhaust; I am planning on true duals with no X-pipe.
Still have to order a chip.

What to you guys think?
 

·
Fry Rice Specialist
Joined
·
4,794 Posts
looks like the intake manifold is without the aluminium crossover???
 

·
Boom.
Joined
·
5,238 Posts
Good job! Just one thing I see...

It looks like you still have the Explorer t-stat housing on your motor; you might need to swap out to the T-Bird housing, not sure if there will be any interference or if the rad. hose will properly meet the Explorer housing.
 

·
Registered
Joined
·
2,638 Posts
Discussion Starter #5
chuacw said:
looks like the intake manifold is without the aluminium crossover???
Yup. I figure it's easy enough to swap the intake. If it goes out, I will swap it out. I questioned this decision on the boards before and one person replied that it will probably hold up. If you guys think differently, please speak up.

Palmguy said:
Good job! Just one thing I see...

It looks like you still have the Explorer t-stat housing on your motor; you might need to swap out to the T-Bird housing...
The T-bird housing doesn't fit. I figured that I could buy a universal hose to fit, unless somebody knows of a housing that will work. (96/97 style?)
 

·
Registered
Joined
·
1,324 Posts
I used the 95 housing with double o-rings; one below the t-stat and one in the normal place. No issues so far.

On the oil filter/lower rad hose adapter, I had to use the 02 gasket. Someone else on here used the 95 gasket and had sealing issues. Just a heads up.

Rob
 
1 - 6 of 6 Posts
Top