TCCoA Forums banner

1 - 11 of 11 Posts

·
Baddest N/A NPI in Canada
Joined
·
2,116 Posts
Discussion Starter #1
Ok, well I finally have a PI intake installed on my 96 TBird! I have a few concerns with it! My car has an old chip from Dennis R in it. With the NPI intake at WOT, I was shifting at 5500 RPM, now I am shifting at 6100 RPM with the PI, this data is taken from the stock tach. Do I need to be concerned with the car shifting at that?

The next thing I noticed is that the car pulls extremely well from a stop, but seems to lack power accelerating past 120 km/hr( approx 75 mph ) is this normal? The car really seems to vibrate at 170 km/hr( 105 mph ) which it didn't do before the intake was swapped! I am wondering if something was done wrong!

The car doesn't appear to act out of the ordinary, so I am just wondering what everyone else who has done this have to say!

The current mods are:
removed air silencer
80mm LMAF
GT intake tube
70 mm SVO TB
P&P Upper intake
PI intake
PI cams
Steeda UD pullies
Mark VIII/GT TC
FRPP 3.73 TL Diff
 

·
MN12 Fanatic
Joined
·
1,459 Posts
Funny, I just did the PI cam and intake swap on my car and my car used to shift at 5500-5600 with an apten chip. But after the swap my car will only shift at 5000 most of the time. And I don't even really feel an increase in power. Trying to figure what the problem is, but no luck!

:(
 

·
Registered
Joined
·
178 Posts
Ok... first of all.. do you have the stock drive shaft?? If you do and you got 3.73 gears, your car is most likely vibrating from drive shaft fatigue at 105MPH. The max DS rpm is about 5000 (not the engine RPM) and its all luck at that RPM. At about 5000 RPM w/ 3.08 gears the speed is about 125MPH. Now, you have 3.73 gears so your top speed shouldn't be any higher than like 90 MAX. As far as shifting at 6100 RPM I don't think thats a concern cause I see that you have a more durable TC. The one thing I can think of thats a minor concern is the powerband might not go that high. I'm thinking the max power band would be about 5800 rpm with PI heads and intake. You might want to have a reburn and the shift points down to about 5500. As for the vibration the only thing I can think is that you have hit more than 90MPH a few too many times and the DS is bending.

Clay
 

·
Registered
Joined
·
3,178 Posts
I'd try to keep it below 6000, both to be nice to the connecting rods and because you probably arent making much power way up there.

Tony, I really think you have a vacuum leak somewhere. How did you match the ports up?
 

·
Moderator, Red Sox Nation Rabid Fan, TCCoAAC Found
Joined
·
3,165 Posts
I've heard nothing but bad things about that SVO TB...
 

·
Registered
Joined
·
1,116 Posts
jordansypek said:
I've heard nothing but bad things about that SVO TB...

Such as........

I have one and have not had any problems with it, just curious what problems others are having.
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
DirtyBird46 said:



Such as........

I have one and have not had any problems with it, just curious what problems others are having.
i heard it whistles at higher rpms and its not actually 70mm, its more like 67mm. i'vwe never personally been in a car that has one or looked at one though. those are just some of the complaints i've heard.

Frank
 

·
Registered
Joined
·
615 Posts
tony you should feel a difference past 3500 rpm, thats where the wheeze out point was. Also do a compression check on any Bank 1 piston and the opposite Bank 2 piston if they numbers are off considerably your timing is off. If you have a vacuume leak your idel RPM will be higher
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
i dont think so, not without a lot of custom work anyway. egr, throttle cables, vaccum lines would all have to be redone/rerouted.
 
1 - 11 of 11 Posts
Top