TCCoA Forums banner

1 - 13 of 13 Posts

·
Chapter Director Coordinator
Joined
·
6,253 Posts
Discussion Starter #1
hey you PI intake swappers

so far, no probs but..

after driving for a bit, i pull into parking spot and pop her in park, and the idle drops to "drive" level, around 600-700rpms.. normally she is at 900-1100rpms while in park

any clue?
 

·
Registered
Joined
·
1,430 Posts
Some reason mine idles at 950 rpm bone stock, and with the a/c on.
 

·
Chapter Director Coordinator
Joined
·
6,253 Posts
Discussion Starter #5
twas a new iac since... um... my cam swap, i think.. maybe before.. and was idling the same even w/ the new iac as it was w/ the old one.

how the hell you clean those damn things anyway? no one has been able to give me a straight answer heh
 

·
Registered
Joined
·
9,966 Posts
jamesD said:
twas a new iac since... um... my cam swap, i think.. maybe before.. and was idling the same even w/ the new iac as it was w/ the old one.

how the hell you clean those damn things anyway? no one has been able to give me a straight answer heh
Preston told me to use Carb cleaner not brake cleaner, unbolt it and spray in to the little bypass doors...

joseph
 

·
Registered
Joined
·
1,746 Posts
Mine shudders when on a cold start from 700 and then pops up to 1.2k and idles there until I put it into drive then it idles around 900 or 800.
 

·
Registered
Joined
·
522 Posts
jamesD

Hope my info helped with the water pump?!?!?! Never heard if it did or if it hurt? Don't worry about the idle for a bit, Comps still trying to figure out what's going on. My would drop down to around 500 and now she's slowly climbing back up close to 1k.

Enjoy the new intake!!
 

·
Chapter Director Coordinator
Joined
·
6,253 Posts
Discussion Starter #11
ya.. it wouldn't come out.. i just chopped it off a bit more w/ my pipe cutter, and put some heater hose on, double clamped it and called it a day.. 2.5days for an intake swap is ridiculous, especially when day 2 was spent half pondering how to do it, and half dodging rain drops heh

when i accel to 60mph moderately, it feels like there is a crap load more power waiting to come out up until i let off the gas.. definite different beast..

we shall see HOW different @ moroso and on the rack the day after :D
 

·
Registered
Joined
·
3,178 Posts
No idle issues here, idles just like stock. Check the IAC and check for any vacuum leaks.
 
1 - 13 of 13 Posts
Top