TCCoA Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
15 Posts
real easy to change to, sitting right there when ya drop the pan. 2 bolts I beleive one 8mm one 10mm, the bracket for TCC is under the bracket for the shift solenoid. so pop both bolts out pull shift solenoid out then tcc, then reverse tcc first then shift.
 

·
Registered
Joined
·
381 Posts
Discussion Starter #7
My car has about 80k on it and I checked all the wireing and connectors.
It just seems that alot of people change the TCC and still no fix. Anyone have any answers?
 

·
Super Moderator
Joined
·
11,017 Posts
For what problem?

Few people have a problem changing the TCC; it's kinda right there when you drop the pan. :thumbsup:

TC problems, otoh, are many and varied...
 

·
Registered
Joined
·
381 Posts
Discussion Starter #9
Have been reading up on CEL problem P0743 which I have and some have changed the TCC and the cel light comes back. I was just wondering if anyone on here has had this problem and it turned out to be something else other than the wireing or TCC solenoid. Im still going to J mod this trans too anyway. Thanks
 

·
Premium Member
Joined
·
649 Posts
Have been reading up on CEL problem P0743 which I have and some have changed the TCC and the cel light comes back. I was just wondering if anyone on here has had this problem and it turned out to be something else other than the wireing or TCC solenoid. Im still going to J mod this trans too anyway. Thanks
Sadly from what I can recall in various Threads over the years the Gurus say that Code routinely pops up on early signs of "slipping" elsewhere in the Tranny (as in pending DOOM) - & JMOD won;t fix that - Our older Main VB's need some Sonnax Parts too when you rebuild the rest of the Tranny.
 

·
Registered
Joined
·
15 Posts
I have the same code and havn't got it yet, I've also heard the PCM sending the wrong signal locking it up early?unfortunatly no local junkyards have a PCM for me. is yours showing any symptoms? Stalling when coming to a stop? mine stalls when coming to a stop and jerks when it shifts into second gear under normal acceleration like the torque converter is locking in second, but not when I get on it hard. dont really feel as though its slipping though. what year do you have? mines a 98 mustang GT. about ready to do a tranny and TC swap out of a 01 and see what happens
 

·
Registered
Joined
·
381 Posts
Discussion Starter #12
I have a 97 tbird 4.6 that has 80k on it. It does not lock into second well as in chirp the tires at WOT but works with out any problems at all. My wife drives the car all the time now. As far as the j mod goes it seems to help these cars out alot as they get older. Im on t bird # 16. Long time fan of these cars.
 

·
Registered
Joined
·
15 Posts
well when mine "locks" in second its more like whenyou dont give a manual car enough gas when letting off the clutch.. kinda jerks back and forth like that. did you check the TCC through the harness with a DMM? see what resistance you get
 

·
Premium Member
Joined
·
649 Posts
well when mine "locks" in second its more like whenyou dont give a manual car enough gas when letting off the clutch.. kinda jerks back and forth like that. did you check the TCC through the harness with a DMM? see what resistance you get
I'm no Guru but both your recent Posts sound like Direct Drum Bushing galled up & getting ready to seize... it happens.
 

·
Registered
Joined
·
381 Posts
Discussion Starter #15
My fluid is clean and has new trans fluid smell. The shifting seems to be right on cue. Even with the CEL lite on its still drives perfect. Will mod the trans and replace the TCC and see what happends. Will let you know how it turns out.
 

·
Registered
Joined
·
381 Posts
Discussion Starter #16
TCC code driving me nuts

Did the J-mod yesterday and installed a new TCC and now she gets some rubber in 2nd and a little chirp out of 3rd. On a sad note I cleared the Cel and it came back today. I figured it would because I ohm tested both new and old TCC sensor`s and the both show 11 ohm`s. Checked all wires from console to trans and all seems good. Engine runs strong and is all stock right down to the air filter box. What to try next?
 

·
Registered
Joined
·
381 Posts
Discussion Starter #17
I was driving the car tonight and the cel light goes out? ! hour of driving, car runs its perfect self. Im sure it will come back on tomarrow.:rolleyes:
 
1 - 17 of 17 Posts
Top