TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
95 T-Bird 4.6 LX, I have flowmasters cat back and i gutted the cats. I put on the 4 new 02 sensors and 2 mil one the rear 02 sensors. New Mass air flow sensor, but the car still idles bad. It stalls at the lights about two or three times a day. When I unplugged the Mass Air Flow Sensor the car runs a lil better it doesn't stall but the idle isn't quite right. I had the codes checked and i got bad 02 sensor and MAF sensor, even after i replaced them and that right side upper 02 sensor is a BYTCH!!. Thanks for the help.


ps. Sometimes in the cold when i start the car it makes a funny sound like a fog horn or something but it goes away when i tap the gas.

Lee:ztoohot:
 

·
Registered
Joined
·
1,799 Posts
In my 97 4.6 LX I had a VERY similar idling problems. Mine sounded sick and had a "cough" tone you could say. What mine came down to be was the idler was bad and needed to be replaced. Once replaced it idled at it's typical RPM and the Bird has been running fine since!

I highly advise you have it checked out.

It (the idler) costs approximately around $150.00 and the dealer would want exactly that much to install it. It is right on top of the intake manifold and infront of the OHC.

Don't let them rip you off!
 

·
Registered
Joined
·
620 Posts
Metalbassist03 is talking about the idle air control valve(IAC), a common problem. Carbon deposits gum up the valve and make it stick. That is the howling noise you hear. It is about 60-70$(if you don't get it from a regular ford dealer). Now the 94-95 cars have a different intake than the 96-97 cars do. On your car the IAC is in the back of your intake manifold, making it a tad difficult to get to. It is still do-able and is only held in by two bolts.

Edit: You could try to clean it once you get it off, but I would just recommend replacing it.
 

·
Registered
Joined
·
1,799 Posts
It didn't on mine actually. Yours is a 94 or 95, so to be honest I don't know, maybe it would in that model, I don't really see why it would in my opinion, but for god's sake don't take an 18 year old's words (mine) for granted without asking other owners first!!
 

·
Registered
Joined
·
620 Posts
Lee95T-Bird said:
ok thanks i try that. Would that cause a check enging light.
It wouldn't throw codes for the o2's and maf, if that's what your asking. The howling sound is the tell-tale sign of a bad IAC, so I would start there before you go spending too much $$$.
 

·
Registered
Joined
·
263 Posts
I had a similar problem on my 95. I thought it was the IAC since the CEL was on. I took it to the Ford Dealer and it was the EGR ports. They had become clogged and needed to be cleaned manually. When the clogged it knocked out a sensor.
 

·
Registered
Joined
·
54 Posts
I had an idling problem too,
I just took the IAC out and used Gum-out (oxygen sensor safe type) to clean out all the carbon deposits. Used a small screw driver and paper towel to clean out all the crud. Idling problem's been solved since. I would clean it first, and if that doesn't work, then buy a new one.
 
1 - 8 of 8 Posts
Top