TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
26 Posts
Got 95 thunderbird running finally after bill helped me out with custom chip, exhaust, maf, and much advice. I have 5.0 forged stroker kit, trick flow cams, pi heads, kooks headers, xpipe, cats,etc.. special thanks to trunk monkey and scp for all their advice. I got some 18 " rims from firestone with 265 35 r 18s on av 14 rims with the the wings look sweet car runs mean. Posting video and pics tomorrow.. thank you ever body for all your help.

Here's some pics though
 

Attachments

·
Super Moderator
Joined
·
12,248 Posts
You need to clean the lens on your camera. If you shot these with your phone after taking it out of your pocket. I bet that's condensation from the temp. change. Give you phone time to match ambient temp or wipe the lens to avoid that problem.

Where are you trying to upload the video to? Set yourself up a YouTube account, upload it there and link to it here.
 

·
Super Moderator
Joined
·
7,564 Posts
That loud ticking noise under the hood does not sound good! Are you sure everything is set up properly with your valve-train and timing chains?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5 (Edited)
No cap on headers where egr was yet pretty sure that's it. I got adjustable timing gears though probably need to have performance shop look at it. I'm scheduled for the 21st of this month so. You don't hear any loud metal clicking when it's running and I put my finger over egr hole on headers and it stops. The video seems to exaggerate it though. But exhaust headers leaks sound like something clicking though too.
 
1 - 5 of 5 Posts
Top