TCCoA Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
605 Posts
Discussion Starter · #1 ·
I just replaced the gears in the power window because it was not working. A day later, the window goes down but comes up slowly. And a few times it would stop for a second of two. Is the motor bad? Did I put to much grease on it? Any ideas? Thanks
 

·
Registered
Joined
·
167 Posts
those little plastic cam gears are sh**t. I greased the crap out of it and then for replacing the cam gears I simply filled in the areas with epoxy, However nothing has a 0% failure rate, make sure that nothing is binding first, I had this happend TWICE.
 

·
Registered
Joined
·
221 Posts
sliders

There are several things you can do to help. If you want to take the time to "test", do them independantly and observe the results. Light oil or WD40 at the joint where the toothed drive arm is bradded to its mounting plate. Kinda a pain to get something down in there.

Next, the little plastic "sliders" and their tracks may be broken or need some lube.

Finally, the felts in the side window tracks themselves may be worn out or have some crud in them or need to be adjusted. I have used numerous things (liquids, sprays) and find that one of the "teflon" type dash treatments work rather easily. Spray into the felt tracks with the window down, then run up and down a few. Yes, it will smear for a short while, but will dry out and leave a slippery film. Wont last forever, but rather cheeeeep! You could just get new felts-----

That reminds me, my Bronco is about due-----again :(
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top