TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
So my '93 3.8 is throwing a code 217, aka Primary circuit failure ignition coil 3.

What causes such a condition for only one cylinder/coil?

I have recently replaced the distributor cap/rotor, wires and plugs, IAC, TPS, vac lines and the timing is right. Am I missing something here?

Because it has the cylinder 3 misfire (which is only at a low rpm like <900RPM) it will barely run at idle unless I have the idle turned up, which somehow makes the problem go away. But given the amount of red lights and stop signs in my area, my low rpm performance is very important.


Anyone know where to go with this one?
 

·
Super Moderator
Joined
·
4,925 Posts
Wait - code 217 is, from my chart, "PCM Detected Coil 3 Primary Circuit Failure". Is it this, or is it cylinder 3 misfiring?

Is this a NA or a SC? The 1993 NA was a single-coil design, the SC was a waste-spark design.

If it's a SC, then coil 3 runs cylinders 2 and 6, not cylinder 3.

I'd start by swapping the coil pack with a spare one, being VERY certain to keep your firing order right (most books list it WRONG WRONG WRONG!!)

RwP
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
Wait - code 217 is, from my chart, "PCM Detected Coil 3 Primary Circuit Failure". Is it this, or is it cylinder 3 misfiring?

Is this a NA or a SC? The 1993 NA was a single-coil design, the SC was a waste-spark design.

If it's a SC, then coil 3 runs cylinders 2 and 6, not cylinder 3.

I'd start by swapping the coil pack with a spare one, being VERY certain to keep your firing order right (most books list it WRONG WRONG WRONG!!)

RwP
It is a NA '93. But yes its giving me that code 217 you mentioned, the ignition coil was replaced withi the last year as well as basically any and all ignition components
 

·
Premium Member
Joined
·
76 Posts
it sounds like a weak coil. sorry to say. I have some problems with the f150s, with a weak or bad connection at the coil. Make sure you ground is making a good connection.
 

·
Super Moderator
Joined
·
4,925 Posts
It is a NA '93. But yes its giving me that code 217 you mentioned, the ignition coil was replaced withi the last year as well as basically any and all ignition components
There's only one thing to say to this - and that's to quote Jeff Foxworthy.

"Honey, you don't have testicular cancer. I don't think you even have testiculars!"

THIS error is not possible on a NA 1993.

I would suggest re-reading the code and verifying that's what you actually got.

'Course, that COULD explain why you're getting it - since there's no third coil, of COURSE there's a primary failure in coil 3!

RwP
 
1 - 5 of 5 Posts
Top