TCCoA Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
605 Posts
Discussion Starter #1
I can't shift out of drive on my car. I don't think its the brake sensor (near the brake pedal) b/c it wouldn't let me shift with the car in the "run" position into neutral to start it up. So took apart the shifter and pushed down on the white plastic piece b/c i HAD to get to work. Well trying to get home I "pushed" down a little to hard the the bottom of the white plastic broke. Any one have any ideas how to fix this?? Or what parts to order to fix the plastic piece. Thanks
 

·
Registered
Joined
·
107 Posts
Here's what I did...

I had the same problem a few years back with my '92SC. I couldn't find a replacement (nobody seemed to know what the hell I was talking about when I asked at parts stores or the dealership). I took a piece of the broken plastic rod to a hardware store (Home Depot) and bought a piece of aluminum rod that was the same diameter. I took the rod home and cut it to the same length as the original (use the two pieces for reference). I had to do some filing on the aluminum to match the rounded ends and to cut the flat spot on one end, but it didn't take very long on the soft aluminum. I then greased it up and dropped it in the shifter. It's still working like a charm. You may have to do some additional filing and polishing to get it to operate smoothly, but it will eventually work just fine...

Hope this helps (if you can't find a stock replacement)
 
1 - 2 of 2 Posts
Top