TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,662 Posts
Discussion Starter #1
I am in the process of putting my 01 trans. back together, and I have the large pump seals that go around the outside edge of the pump, but I forgot to get new o-rings for where the pump slides onto the input shaft. Looks like there are 2 o-rings. With this new of a trans., would I need to bother replacing these, or can I get away with leaving them alone? I really don't care either way, and would rather replace a $2 o-ring, than have it cause the trans. to puke later on, but hey, a $1 saved right now is better than nothing, if I can help it.

Jay
 

·
Premium Member
Joined
·
6,617 Posts
I think you are talking about the 1 piece teflon seals(white) leave them alone, you can only damage them by changing them.
 

·
Registered
Joined
·
2,662 Posts
Discussion Starter #3
I guess. I could have swore that there was a black O-ring near the end of the pump housing. I'll grab a pic when I get home and double check. No need to create a problem when I *should* be done. Thanks Alan

Jay
 

·
Registered
Joined
·
2,662 Posts
Discussion Starter #5



Ok,

A.- I am a moron. The ring I was thinking about is actually a metal snap ring. There seem to be several on the end. Nevermind on that.

B. The seal that is between the 2 parts of the pump assembly (the yellow stripe in the pic above). Should I even bother that? It looks fine, but hey, what do I know? I have 2 new seals for mounting the pump to the rest of the trans., so that's cool. I know where/how those go in. And I saw the nylon ring you referred to first, it's yellow, and is sitting on the backside of the pump. Not bothering it at all per your instructions.

thanks!

Jay
 

·
Premium Member
Joined
·
6,617 Posts
FordMan77 said:
Ok,

A.- I am a moron. The ring I was thinking about is actually a metal snap ring. There seem to be several on the end. Nevermind on that.

B. The seal that is between the 2 parts of the pump assembly (the yellow stripe in the pic above). Should I even bother that? It looks fine, but hey, what do I know? I have 2 new seals for mounting the pump to the rest of the trans., so that's cool. I know where/how those go in. And I saw the nylon ring you referred to first, it's yellow, and is sitting on the backside of the pump. Not bothering it at all per your instructions.

thanks!

Jay
There are two seals on the pump. The o-ring which you see in that picture painted yellow. Then there is a black gasket that seals the pump to the case. I'm not sure but I think the nylon you are referring to is the thrust spacer.
 

·
Registered
Joined
·
2,662 Posts
Discussion Starter #7
Yep, then those are the 2 I have. the one from pump to case I know, and then the other must be for the one w/ the stripe on it. Thanks for straightening me out on that. I tend to overthink things when it's something expensive that only takes one f-up to destroy.

Appreciate it

Jay
 
1 - 7 of 7 Posts
Top