TCCoA Forums banner

1 - 5 of 5 Posts

·
MaleWhore
Joined
·
2,640 Posts
Discussion Starter #1
well i just did the exhaust a few weeks ago, and i havent had time to check why my chech engine light has come on...i am running catless, with MIL, and just asking weather it could be caused by the exhaust or not...i know i have to run the codes to truly know what it is...but i havent had time
 

·
Premium Member
Joined
·
3,247 Posts
I always get a laugh at some of these posts.

My Check Engine Light is on ? Any idea why?

Not trying to be mean, but why bother soliciting opinions from people over the internet, when you could just run down to the nearest Midas, Monroe, AutoZone, local shop, etc., and throw anywhere from $0 to $20 at them to retrieve the codes?

It would almost take the same amount of time as it would to sit down, boot up the computer, type a new post, and then WAIT for who knows how long for someone to reply with a "Clean the MAF and report back" answer.
 

·
MaleWhore
Joined
·
2,640 Posts
Discussion Starter #3
well it dont take time at all to type a thread for me...but i see your point...but there is nothing i can do about it now is there?
 

·
Premium Member
Joined
·
3,247 Posts
My point is more this;

The sooner you can identify why the CEL came on, the cheaper it usually is to repair the problem, than if you drive around for days or weeks (or even months) with the light on.

It could be related to your exhaust mod's, but it could also be something else.

For example, when a MAF goes bad, it can cause the engine to run rich.

If you let it run that way for too long, it will ruin your cats.

Go price a brand new three-cat unit from Ford.
 

·
MaleWhore
Joined
·
2,640 Posts
Discussion Starter #5
i totaly understand...u have a very good point...i do i understand that my thread was point less, i was just wondering if it had happened to someone before when running catless with MILs....if that could still cause a CEL to come on even thought the MILs were installed....
 
1 - 5 of 5 Posts
Top