TCCoA Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
803 Posts
Discussion Starter · #1 ·
Push the power button and nothing happens. Fuses are fine. Any ideas?
 

·
Registered
1993 T'Bird
Joined
·
1 Posts
Push the power button and nothing happens. Fuses are fine. Any ideas?
Can you share a little more? Was the radio recently installed? Has operation been intermittent?

My first thought would be to pull it from the dash and test the fuse on the back of the radio (if so equipped) and continuity at the wiring harness. That'll differentiate between an electric supply issue and failed radio.
 

·
Super Moderator
Joined
·
11,671 Posts
New headunits are cheap;
I wouldnt **** with it for $59-75 bux.
There are new Alpine headunits for $150.
 
  • Like
Reactions: Dantb94 and RalphP

·
Super Moderator
Joined
·
5,718 Posts
What Grog6 said.

Plus you'll pick up Bluetooth and USB compatibility towards the higher end. (Shucks, the one I have in my Dakota even does .MP4 movies and supports a rear view camera, and it was a whopping $30 ... albeit from Honest John's Laundry and Electronics.)

RwP
 

·
Super Moderator
Joined
·
11,671 Posts
Since I let the other cars go, I have an Alpine deck for Lazarus. :)
 
  • Like
Reactions: RalphP and XR7-4.6

·
Registered
Joined
·
803 Posts
Discussion Starter · #6 ·
Can you share a little more? Was the radio recently installed? Has operation been intermittent?

My first thought would be to pull it from the dash and test the fuse on the back of the radio (if so equipped) and continuity at the wiring harness. That'll differentiate between an electric supply issue and failed radio.

Stock radio / CD player
 
1 - 6 of 6 Posts
Top