TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Ive had this problem for a little while but now its time to fix it. Some times when I rev the engine, it back fires. I noticed that there is also a rattle or something coming form the engine. Im thinking its a broken valve spring or something. How can I check to make sure before I tear down the engine? Will a compression test tell me? Also the cars has been lacking the power that it once had. 94 LX 4.6 96,000 miles
 

·
Registered
Joined
·
7,758 Posts
If it were me, the first thing I would do is a compression check and then go from there. If that was not conclusive, I would do a leak down test. That will give you a good indication of the condition of the pistons/rings/valves.
 

·
Premium Member
Joined
·
441 Posts
96,000 isn't alot of miles for a 4.6. Is the rattle towards the front of the engine? I'm thinking timing chain tensioner, maybe chain slack is causing the valve timing to change = backfire? just a thought.

Bob
 

·
Registered
Joined
·
41 Posts
Discussion Starter #4 (Edited)
I jsut turned 100,000 miles on my car. Its 94 LX 4.6, Ive been meaning to do a compression test but I havent got around to it yet. I have noticed that when I I go WOT the engine starts to make a rattling sounds when it gets towards redline. Can this be from a broken valve spring or what? Any other recomendations on tracking down this noise?


Took the MAF apart and cleaned it real good. That fixed the problem, and I also ran Sea foam through the intake. The car runs liek a dream now.
 
1 - 4 of 4 Posts
Top