TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
Ok Ive had this problem for quite along time but never payed any attention I have been having a rough idle when stopping (applying the brakes) but idle returns to normal position when fully stopped and also i have had a rough idle after just putting fuel in the car but goes away after driving for a little while (Fuel Regulator Maybe)anyone else have this problem. any help is greatly appreciated.

Justin
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
well I have little or no idea how to help you Justin, but since no one else is I'll just throw my word in.

Sounds like something to do with vacuum and something with fuel. Since the FPR is vacuum controlled, maybe you're right about it being the FPR. Do you have a fuel pressure gauge, or could you rent one? Then test the fuel pressure while someone steps on the brake or right after you fill up test the pressure. Or just buy an adjustable fpr from mn12performance.com :D

-Thomas
 

·
Registered
Joined
·
25 Posts
I think Thomas is on the right track on this one but I'm going to stick my neck out here and say check for a vacuum leak where the main line comes off the intake manifold. Also check for colapesed lines if they aren't leaking they may be colapsing when a large demand for vacuum is needed such as when you apply the brakes.
 

·
Registered
Joined
·
207 Posts
Discussion Starter #4
Yeah I was thinking that it was a vacuum leak but dont really hear any hissing whats the best way to check for them with a tube?
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
I don't get why the idle drops when applying brakes but not at idle. Because vacuum is very low at idle so if there were a leak it would probably affect the idle.

Justin, there's a meet at Sprockets indoor go-karting center in Des Moines on the 21st. Maybe you could make it on over and we could all take a look at it?

-Thomas
 

·
Registered
Joined
·
31 Posts
Hey what's up everybody Im having the same problem as Justin. I have 95' T-Bird 3.8. The check engine light has come on, and now when I brake at a stop light the car will shudder. Also when I go in reverse down a hill the car will sometimes drop so far in RPM that the engine will shut off. Anytime I shift from idle, the rpm drops, and the dash flashes. Its as if the ngine shuts off for a 1/2 a second. Is it the O2 sensors??? Vaccum leak?? What should I do? The head gasket was replaced about 10,000 miles ago, and the mileage is at 146,000. I get oil changes regularly, and replaced a spark plug wire in the summer ( one was brushing against mainfold), along with all the plugs. Any advice? ALso I seem to be getting less gas mileage. I filled up the 18gallon tank and im getting about 260. Is that normal? I feel as if I was getting closer to 300. I sometimes can control this shudder if I pump the brakes when I stop a little, or start braking early.:( I just wanna take care of this car.
 
1 - 6 of 6 Posts
Top