TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
My 97 4.6L developed a rough idle on the way home Fri. night.
Only at idle no CEL, worse when in gear.
I went out today to check it again and I got a CEL this time.

I tried swapping the IACV for the one in my other 97 and that seems to helped some. I also cleaned the MAF in the process, it was pretty dirty.
As I said it does seem better, I may go ahead and get a new IACV just to be sure.

But what I wanted to ask was if the computer will take a while to relearn and that my problem may still get better?
Also I am going to go ahead and replace the PCV. Before I do though can anyone tell me the size of the hose that is right below the IACV? It goes over to the PCV. It looks pretty cracked.

BTW, the car has about 76K on it.

Thanks in advance.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #2
Well I still have a rough idle this morning plus a CEL.

Still need to replace PCV.

Any other suggestions before I order some parts? Am thinking plugs and wires.

Thanks,
 

·
Premium Member
Joined
·
3,247 Posts
Royalblu said:
Well I still have a rough idle this morning plus a CEL.

Any other suggestions before I order some parts? Am thinking plugs and wires.

Thanks,

I have one.........get the codes scanned.
 

·
Registered
Joined
·
2,894 Posts
scan the codes almost anything could be the problem, if its really rough at idle then clears up as more and more revs come, id guess could be the plugs, i had one foul out to the point it didnt fire unless i reved the crap out of the engine, at idle sounded like a carberated 6 cylinder with issues, was kinda scary
 

·
Registered
Joined
·
2,894 Posts
but p.s. thats a needle in the hack stack guess, needed to know what code is throwing
 
1 - 6 of 6 Posts
Top